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Introduction

Welcome to the next generation of master scheduling software! We are delighted to introduce
Classifier 2003 — the latest step in a twenty-two year legacy of the best in school scheduling software.

In 1981 there was no such thing as a master-scheduling program for a microcomputer. The Classifier
started a revolution that forever changed the way schools schedule their students! For the past twenty-
two years the keepers of this flame have lovingly crafted The Classifier family of master scheduling
software through over fourteen generations of development.

The newest edition of this time-tested application offers the solid reliability schools expect from
Surfside. Classifier 2003's unparalleled ease-of-use plus many new features make this the very best,
most powerful edition of The Classifier ever!

Classifier 2003 is a complete scheduling software package designed to manage the otherwise tedious
task of building a master schedule and student schedules for your school.

A powerful feature set, plus the ease of use found in next-generation Windows applications makes
using the Classifier 2003 easier than ever. No longer is building and maintaining your school's master
schedule a daunting task.

This “quick start guide” is intended to offer essential information about the program and to instruct you
in the basics of how to use Classifier 2003 to schedule your school. For veteran users of Surfside
products, be sure to read the boxes entitled “Notes for Legacy Users”. These notes provide
comparisons to similar features or terminology found in our earlier products to help you in learning
Classifier 2003. Even if you’re new to our product family, you may find these notes informative to
your understanding of how Classifier 2003 works.

In addition to this “quick start guide”, the Classifier 2003’s extensive help system has the complete on-
line manual for reference on any part of the program discussed here. We recommend that you use the
help system to supplement the information found in this article.
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Overview

The Classifier 2003 is truly a “next generation” product. It works much differently than any prior
scheduler we have published and, indeed, differently than many other scheduling packages on the market.
The most important thing to remember about Classifier 2003 is that you are not required to take a linear
path through this program. This program allows you to move all over the place without re-running blocks
of programs. Part of the reason for this is that Classifier 2003 builds and populates the master schedule all
at the same time.

If you have used our older scheduling packages, you’ll want to pay special attention to the “Note for
Legacy Users” boxes presented throughout this guide. Even if you’re new to our product family, you may
find these notes informative to your understanding of how Classifier 2003 works.

All schedule information is contained in a single database file. Data may be imported and exported to and
from many different formats. Data from current Surfside programs may be imported into Classifier 2003
and data from Classifier 2003 may be sent back to Surfside Solution 111, as well.

Note for Legacy Users

A major conceptual difference between your older program and Classifier 2003 is the way the program
receives your constraints. In all of the prior scheduling packages we published, the “pseudo student”
was used to devise constraints and express them to the program. Classifier 2003 receives constraints in
a much more logical manner — you tell the program about the teacher and room assignments for each
section ahead of time and the master scheduling “engine” uses this information to determine teacher and
room constraints when the schedule is cast. We will talk more about other means of expressing
constraints further on in this document.

Creating a New Database

The first step in the scheduling process is to create a new database file. All schedule information is
contained in a single database file. To create a new database (starting completely from scratch), click
File=>New Database.

Users of an existing schedule or database product might wish to import their data so as not to have to
reenter it from scratch. If you are using a Surfside schedule product, you may import all student
demographic data as well as all of your existing schedule information. Users of other, non-Surfside
products might be able to import student demographic data only, if your software can export to a
compatible file format. To import data from another program click File=>Import. The import process
can create a new database for you, so it is not necessary to create a blank database first.

Most users of existing Surfside products will want to create their database with the File=>Import
method. If you’re using a non-Surfside administrative product, we’ll be happy to talk with you if you
have questions about the import function.

Setting Basic Schedule Parameters

After the database creation process is completed (whether by creating a new database or importing
data) you will be asked to set some basic schedule parameters. You will want to adjust the settings for
periods, blocks and cyeles to fit the schedule layout you will use for your school.

Periods in the day are essentially what they appear to be with these exceptions:
*  Each period can be renamed to better describe your schedule format.
*  Each period can be assigned a beginning and ending time at which it meets.

If a period is renamed (i.e. period one is renamed to “Homeroom”, the name “Homeroom” will be
displayed everywhere in place of period one. This includes all reports and all screen displays, such as
adds/drops. You may rename a period at any time.
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Blocks are somewhat analogous to semesters. The most common use of blocks will be standard two-
semester, trimester, and four-block format. Each block can be named something other than the default
value. As with periods, a block can have a starting and ending date.

Assigning each period a beginning and ending time later allows the program to respond to your “Where
is this student now?” query.

Cycles can be thought of as “days of the week™ and can be used to allow courses to meet only on
certain days.

To change schedule parameters at any time after the initial database is created, go to
Schedule=>Schedule Parameters.

Note for Legacy Users

Cycles - In previous Surfside schedulers, a course meeting at a given period would meet at that period
for every day for the entire semester. Many users would get around the obvious limitation by including
multiple names into one, such as “PE/Health”. That is no longer necessary. By setting up multiple
cycles, a course can be told to meet on Monday, Wednesday and Friday, while another at the same
period could meet at Tuesday and Thursday.

Schedule Paths - Previous Surfside schedulers store their data in separate “thisyear” and “nextyear” data
paths. Classifier 2003 maintains a single, centralized course database. It is not necessary to prepare
data files for scheduling or to perform any initialization functions. It is also not necessary to take a
linear path through the schedule building process as you did in our earlier products.

Student Database

All students are maintained in the student list that you can access by clicking Lists=>Students.
Students may be added, deleted and changed at any point throughout the year.

The program provides a few basic, pre-defined fields such as name, class, birth date, gender and race.
You can add any number of user-defined fields. Once a student is added to the student list, his record
is available throughout the entire program without your having to complete any “posting” or “copying”
procedures. If you have imported data from another product, student data should already be present
and can be modified as necessary.

One very useful option is the ability to change the enrollment status of a student. Setting students as
“not enrolled” prevents them from showing up on most reports such as schedules and class rosters. The
student will still be extant in the database and can be edited as normal. You would use this setting if a
student withdrew from school or if you are entering new students for a new year and do not want them
to show on any reports until a later time.

Build Management

Builds are an integral part of Classifier 2003. Each “build” is a location where a set of schedule
information can be stored without affecting the current schedule information. Builds provide a means
of making changes to the master schedule and student schedules without affecting the “live” schedules.
Builds can be used during the schedule building process to provide “what if”” scenarios or to begin
scheduling for a new year before the current year is complete.

To view and manage your builds click Builds=>Build Management. Before you begin the schedule
process you should define a single build where all course meeting times, constraints, links, and student
schedules will be placed. If you would like to test out what would happen to the schedule if you were
to constrain a course differently you might use the Build Management function to duplicate the current
build. Using the new build you can make your constraint changes — if the changes do not work out,
you can switch back to the initial build.

It is important to understand that builds do not contain a separate copy of all of your data — just course
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meeting times, constraints, links and student schedules. Basic course information such as the number
of sections, meeting length and teacher and room assignments are not linked to any builds. Changes
made to this basic course information - or any changes made to the student list - are made across all
builds.

Course List

Classifier 2003 provides a single course catalog for managing all the particulars of your courses. To
view and manage your list of courses, click Lists=>Courses. Once a course is added to the system and
set up to your specifications, it can be used instantly throughout the entire schedule program. Courses
may be added, deleted, renamed or otherwise modified at any point through the school year.

Certain changes to courses, such as removing existing sections or deleting a course entirely will affect
existing student schedules or requests. Unlike some programs that treat changing course information in
the middle of the year a “dangerous” process, Classifier 2003 was designed to provide you with a safe,
flexible system for making changes to course and master schedule information at any time.

Sections and Meeting Times

When defining a new course (or editing an existing course) you also define the section properties for
the course. In Classifier 2003 the properties of each section consist of teacher, room, seating limit and
meeting time.

Since it is not necessary to take a “linear path” through the schedule process, you may assign the new
section a meeting time and teacher/room when you create the course if you so choose. If you have not
yet generated the schedule, the meeting time of a section is irrelevant — when you have the program
build the master schedule those sections may be moved to different times. However, teacher and room
assignments established for each section will be used to keep those sections from meeting at the same
time, thus satisfying your teacher and room constraints. If you need a section to meet at a particular
period, how to do this is presented in the “constraints and links” section below.

It is best to enter teacher and room assignments for each section before building the master schedule.
With this information available the program will be able to do a much better job not only satisfying
your student requests, but also your teacher and room constraints.

Section information can be viewed directly from the course list, by clicking on the Sections tab. You
can also use the dedicated section list by clicking Lists=>Sections to display a list of all course
sections at once.

Note for Legacy Users

Pseudo students — Classifier 2003 does not use “Pseudo students”. Instead, the teacher and room
assignments are examined when the master schedule is cast in order to prevent sections of courses
being taught by the same teacher or in the same room from meeting at the same time. In addition,
courses can be constrained to meet only at certain periods (or prevented from meeting at certain
periods), which was another major use of pseudo students.

Singletons — A singleton is a course with only one section. In many scheduling products, singletons
have special meaning because these courses were treated differently — they’re scheduled first and
then the rest of the schedule falls in around them. This is not the case with Classifier 2003. From
the user’s perspective, the program treats a single-section course no differently than any other
course. The master schedule builder might analyze and treat the course a little differently because
there are not as many options when scheduling singletons, but no other special consideration need
be given to them.
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Constraints and Links

Barring any other restrictions, when a master schedule is cast the courses are placed at the meeting
times that best allow the student requests to be satisfied. Add to this the additional constraints of
teacher and room assignments and you have a schedule that will allow both your teachers and students
to be satisfied. Naturally, there will be times when further control is needed. This is where constraints
and links come into play.

Constraints allow you to define units of time where the course is allowed to meet — or when it is not
allowed to meet. By default, a course can meet any time during the day for all blocks. It is possible to
prevent a course from meeting at any given period or group of periods, or even to force a course to
meet only at a specific period. Constraints are the primary tool used to keep courses out of certain
times or to force a course to meet at a certain time.

Note: When you define constraints there is a check box called “affect all sections” — if this box is
checked, your constraints will be applied to all sections of a course. In default mode (which has the
box not checked) you can devise different constraints for each section of a course.

Links are a way to force courses to “follow” other courses, regardless of where they might be placed.
Certain courses, such as lab courses, must meet adjacent to their parent course. Setting up a link to
have the lab course meet one period before or after the parent course would accomplish this task.
Several other link types are available such as meeting at the same time as another class, or meeting
anywhere except the same time as another class. Links are defined individually for each section of a
course, so it is possible to have one section be linked to another class in one way, and another section
linked in a different way, or not linked at all.

Course links and constraints can be viewed directly from the course list, by clicking on the Constraints
and Links tabs. When viewing the Sections list you can see if any constraints or links have been
defined for a section by looking for the check mark in the appropriate column.

Teachers and Rooms

Teacher and room assignments are first managed by clicking Lists=>Teachers and Lists=>Rooms.
Both teachers and rooms must be defined before they can be assigned to a course. Once they have been
defined on the teacher and room lists you can use them in other parts of the program.

There are times when you might not know exactly who will be teaching a section of a course. In those
cases you should create a fictitious teacher name as a placeholder. You can assign the temporary
teacher to the individual sections of a course so that those sections are kept from meeting at the same
time by the master schedule generator, and when you determine who will be teaching the courses the
teacher name can be changed accordingly. The same applies for room assignments.

Entering Student Requests

The program uses student course requests to automatically build a master schedule and to assign a set
of courses to individual student schedules after the master schedule has been created. Requests can be
assigned any time after the course list is established. When the program builds the master schedule it
examines the student requests and tries to accommodate as many requests as possible, while at the same
time trying to observe all of your other constraints.

It is not necessary to enter requests before creating sections of courses or assigning teachers and rooms
to those sections. It is not necessary to follow a linear path through Classifier 2003. Requests need
only be entered before building a master schedule.

Several methods of entering requests exist to help make the data entry process more convenient.
Common courses can be used to place several courses on each student’s request list, such as in cases
where students in the same grade must take the same “core” courses.

In addition to the standard method of assigning course requests to students, you can assign student
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requests directly to a particular course. This procedure allows you to display a course and see who is
currently requesting it, then make the necessary changes. Standard course request entry is commenced
from the student list on the Requests tab. The “reverse method” of entry is rendered on the Requests
tab of the course list.

Pre-Registration Lists

At any point during or after the process of entering student requests you can print several reports
showing pre-registration counts and lists. To produce a report with a count of the number of students
requesting each course you would click Reports=>Course List. There are also reports to print student
requests and to search for students who have an insufficient number of units requested.

In addition, the section list, which is an interactive view of all your courses and sections, maintains an
up to date count of the number of students requesting each course. Click Lists=>Sections to view this
list.

Building the Master Schedule

Classifier 2003 will generate a master schedule for your school.

Once your course list and student requests are established, you can have the program automatically
build a master schedule and student schedules by clicking Schedule=>Build Schedule. The “build
schedule” procedure analyzes student requests, course constraints, teacher and room assignments, links
and several other factors and arranges a schedule that will best satisfy all of these requirements.

A unique function in Classifier 2003 is “slider controls” that give you a voice in how much weight is
given to several factors during the build of the schedule. These factors include course balance, period
and block balance, student abandons, race balance, gender balance and class balance. The program
comes with default settings for each of these items and those will work for most schools. However, if
you wish to experiment with weighting each of these factors differently please feel free to do so.

The results of building the master schedule are stored in the currently selected build. After building a
schedule the meeting time for courses would have been adjusted as well as the final student schedules.

If a master schedule is already in place and you rebuild the schedule, courses will be moved to different
times and students will have different schedules. If you want to try “what if”” scenarios to find out if
making certain changes will help the schedule, you should first define a new build and run the

“test” schedule in the new build. Using builds in this manner allows you to revert to a previous point in
time, should the new master schedule not be to your liking.

The “build schedule” function offers an option to re-populate student schedules and not modify the
master schedule should it be necessary to do so. This would be similar to running the Balance Section
Loads program in our earlier schedule products.

Schedule Building Utilities

Often the exigencies of scheduling require several attempts before you get things exactly the way you
want them. Many factors come into play when building a schedule — from teacher and room
constraints to student conflicts. Several tools are available to overcome these obstacles.

An interactive Conflict Matrix can be used to determine which courses must meet at different times and
is useful to use before constraining several courses to meeting at the same time. Period Usage lists,
interactive Class Roster lists, and interactive Master Schedule lists are additional tools that help see the
results of a schedule build.

While the schedule building process is fully automated and allows you to ignore some complexities
involved in master schedule creation, these tools do have their uses and can be used to fine-tune your
master schedule.
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Adds and Drops

Final student schedules can be viewed from the student list by clicking the Schedules tab of the student
list. A schedule is automatically created for each student when the master schedule is built, based on
his or her requests. Individual schedules can be modified at any point in time to add, move or delete
courses from individual periods, blocks and cycles.

Final schedules are maintained separately from student requests. This differs from the way some other
schedule products work. After a master schedule is built and student schedules created, changes made
to the final student schedules do not affect the original set of requests for the student. If you later
rebuild the master schedule the original requests are used to again make the schedule for the student.

Classifier 2003 offers both “standard” and “linked” editing of a student schedule.

A standard “add” of a course to a student’s schedule will place the course at the selected period for all
blocks that the course is being offered. If there is already another course at that period in the same or
different block, the old course will be replaced in favor of the new one.

To prevent this behavior and allow both courses to coexist at the same time, click Linked Edits and
future changes to the schedule will affect only the current period, block and cycle and not overwrite the
other course.

Note for Legacy Users

Overrides - Some of our previous master scheduler use “overrides” for purposes of assigning two

courses at the same period, each in a different semester. This method is no longer used. Instead,
Classifier 2003 allows “unlinked” editing to accommodate such changes.

Printing Class Rosters and Schedules

Once the master schedule is in place and all adds and drops have been made, you can print up-to-date
class rosters and final student schedules. Several other reports are available. Click the Reports menu
for a complete list of available reports.

Additional Resources

This guide has touched upon the basic concepts and procedures needed to use Classifier 2003 to build
and maintain a schedule for your school. Please refer to the online help system for more specific
information on each part of the program.

How to Get On-Line Help

The Help system contains several efficient methods to answer your questions about the program. Press
F1 from anyplace in the program to display the on-line help system. To display topics for that
keyword, type a word or phrase in the Index tab. If that does not find what you need, switch to the
Search tab and type your search text. You may browse the entire contents of the help documentation
by switching to the Content tab and browsing through the various books and pages.

Get Up-to-Date Information on our Website

Visit our website at www.theclassifier.com for the most up-to-date information about this product.
You may find answer to common question, updates and other documents there that will help to answer
your questions.
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Keep Your Program Up-to-Date

Classifier 2003 has an automatic update feature that allows it to acquire maintenance updates at any time.
To ensure that you are using the most current version of the program, run the Help=>Check for Product
Updates function at least once a week.

Contact our Technical Support Staff

Our technicians are available between the hours of 9 a.m. and 5 p.m. Monday through Friday, Eastern
time.

Y  Phone: 800-942-9008 or 508-255-1079 — the Classifier 2003 hotline is at extension 240.
Y  Fax: 508-255-9520

Your first ninety-days of technical support is free with the purchase of the program. After that period
ends, it is necessary to purchase an “Intensive Care” technical support plan. Contact customer service
for further information.

Email our Technical Support Staff

Email support is available virtually 24 hours a day. Our technicians usually respond very quickly but
will always respond to your question within two business days.

Y  Email: support@surfsidesoftware.com



