
1



Table of Contents
Lighthouse Gradebook......................................................................................................................................4

Introduction..................................................................................................................................................4
Installation....................................................................................................................................................4

Installing from the website......................................................................................................................4
Installing from the CD.............................................................................................................................4
A note about access rights.......................................................................................................................5
Checking for product updates..................................................................................................................5
Licensing the software.............................................................................................................................5
Removing the program............................................................................................................................5

Launching the Gradebook Program..............................................................................................................5
Creating Your First Gradebook....................................................................................................................6

Gradebook wizard....................................................................................................................................6
Saving your gradebook file......................................................................................................................6
Creating your gradebook from Surfside Lighthouse...............................................................................7
Copying your gradebook to another computer........................................................................................7

Getting to Know the Gradebook Screen.......................................................................................................7
Navigating around the editor........................................................................................................................8

Getting help..............................................................................................................................................9
Toolbar and menu bar..............................................................................................................................9
Course bar................................................................................................................................................9
Columns area...........................................................................................................................................9
Students and grades...............................................................................................................................10
Averages................................................................................................................................................10
Undo.......................................................................................................................................................10
Right-click context menus.....................................................................................................................10
Multiple selections.................................................................................................................................11

Configuring your Gradebook.....................................................................................................................11
Terms and semesters..............................................................................................................................11
Categories..............................................................................................................................................12
Grading symbols....................................................................................................................................12
Predefined grading symbols...................................................................................................................12
Grading scales........................................................................................................................................13
Preferences.............................................................................................................................................14

Courses and Students..................................................................................................................................15
Adding courses......................................................................................................................................15
Adding students.....................................................................................................................................15
Dropping students..................................................................................................................................16
Changing a student's record...................................................................................................................16
Sorting students......................................................................................................................................16

Entering Grades..........................................................................................................................................17
Adding columns.....................................................................................................................................17
Entering grades......................................................................................................................................18
Extra credit columns..............................................................................................................................18
Sorting columns.....................................................................................................................................18
Filling grades.........................................................................................................................................19
Adjusting grades....................................................................................................................................19

2



Override a student's average grade........................................................................................................19
Understanding the Weighting System........................................................................................................19

Grouping................................................................................................................................................20
Weighting...............................................................................................................................................20
Column weighting..................................................................................................................................20
Category weighting ...............................................................................................................................21
Term weighting......................................................................................................................................21
Averaging methods................................................................................................................................22
Explain student's average report............................................................................................................24

Reports........................................................................................................................................................25
Navigating the preview screen...............................................................................................................26
Common report tasks.............................................................................................................................26
Student selection....................................................................................................................................27
Term selection........................................................................................................................................27
Progress report.......................................................................................................................................27
Scores.....................................................................................................................................................28
Missing assignments..............................................................................................................................28
Assignment report..................................................................................................................................28
Class summary.......................................................................................................................................28
Spreadsheet of columns.........................................................................................................................28
Explain student's average.......................................................................................................................28

Sending averages to Surfside Lighthouse...................................................................................................28
Uploading grades to MyStudentData.com.................................................................................................29

3



Lighthouse Gradebook

Introduction
The Lighthouse Gradebook is a program designed to mimic a standard pen-and-
paper gradebook to track student grades across an entire school year.  Because the 
program uses an industry standard look and feel teachers can start using the 
program immediately and be proficient in a very short time. Powerful tools are 
available to track a student's performance and produce professional quality reports 
quickly and easily.

Many screens throughout the program offer a Help button that provides you with 
detailed instructions on that specific screen. By clicking the Help button you will 
be able to read a topic covering all of the elements you see on that screen, as well 
as discussing some key concepts related to what you're currently working on.

For more general help press the F1 key from anywhere in the program and you will 
be brought to the online help system. Using the navigation pane on the left hand 
side of the screen you can look for help topics, browse the index, or search for 
specific words or phrases.

If you need help beyond what is offered in this manual or in the on-line help 
system, you can turn to our technical support staff for assistance. If you are using 
the free, unlicensed version of the software you can e-mail our technical support 
staff at gradebook@surfsidesoftware.com and we will reply on a time available 
basis. Licensed users can e-mail or call our toll free number supplied to you at the time of purchase.

Installation
We recommend that you install the Lighthouse Gradebook by downloading the program from our website at 
www.surfsidesoftware.com.  This will ensure that you have the latest release with the most up-to-date features.  If you must 
use the CD to install the program be sure to check for updates when you first run the program.  You can check for updates 
at any time by clicking Help=>Check for Updates within the gradebook program. 

Installing from the website
1. Download the gradebook software from our website at www.surfsidesoftware.com. Save the installation file to 

your computer.  Once it has finished downloading, double-click the file to begin the installation process.

2. At the welcome screen click the Next button to move to the next screen where you can choose the target location 
on your hard drive. This is the folder where the program files will be installed.  Unless you have a very good 
reason for doing so we recommend you keep the default location and click Next.

3. Click the Next button to begin the installation. Files will be copied onto your computer and a shortcut created on 
your desktop with which to launch the program. When the setup program has finished installing the gradebook 
click the Finish button to exit.

Installing from the CD
1. Insert the Lighthouse Gradebook CD into your CD-ROM drive. If the installation's welcome screen doesn't come 

right up then you might have auto-run turned off and will need to begin the installation manually. To do so, open 
My Computer, open your CD drive, and double-click the SETUP file.

2. At the welcome screen click the Next button to move to the next screen where you can choose the target location 
on your hard drive. This is the folder where the program files will be installed. Unless you have a very good reason 
for doing so we recommend you keep the default location and click Next.
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3. Click the Next button to begin the installation. Files will be copied onto your computer and a shortcut created on 
your desktop with which to launch the program. When the setup program has finished copying the file click the 
Finish button to exit.

A note about access rights
The Lighthouse Gradebook was designed to be as friendly as possible on secure computer systems such as Windows Vista. 
The initial program installation may require local administrative rights due to the fact that several system files must be 
installed and registered by Windows. Once installed, the program accesses only those areas of the computer that are 
typically available to a restricted user. This means that no areas of the registry are accessed and file-level access for 
important program information is limited to certain areas of \Documents and Settings.

Checking for product updates
You should periodically check to see if any updates to your software are available by clicking Help › Check for Updates. 
Such updates are free of charge and include additional features or fixes.

Licensing the software
The Lighthouse Gradebook can be run in either licensed or unlicensed modes. Either way offers a fully functional 
gradebook system that never expires and imposes nearly no limitations on usage. 

To license your software you will need to purchase a registration code from our sales department by calling 800-942-9008 
ext 110 or by sending an e-mail to sales@surfsidesoftware.com.

Once you have obtained your license information you can enter it into the program by selecting Help › License Your Copy.

There are three advantages to purchasing a license for your program:

● Access to prioritized technical support via e-mail. In the case of a school-wide license you'll also gain access to 
telephone support via our toll free phone number.

● The removal of the wording "Unlicensed Copy" from all printed reports.

● The ability to submit final averages electronically to a compatible student information system, such as Surfside 
Lighthouse.

Tip:  You must enter the license name and serial number exactly as they were supplied to you.  The 
name is case sensitive, while the serial number is not.  If you received the license information via e-mail 
it may be easier to copy/paste the information directly.

Removing the program
Should you wish to completely remove the Lighthouse Gradebook from your computer follow these easy steps:

1. Open the Windows Control Panel. On Windows XP you can do this by clicking Start › Settings › Control Panel.

2. Double-click the Add/Remove Program icon

3. Locate the Lighthouse Gradebook program in the list and click Remove to begin the un-install process.

Launching the Gradebook Program
The installation of the program (described above) will create a new shortcut on your desktop, called Lighthouse 
Gradebook.  Double-click this icon to launch the program.  You may also launch the program by clicking the Start menu, 
selecting Programs, and locating the Lighthouse Gradebook program group.
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Creating Your First Gradebook
Whether you are running the program for the first time or you just want to start a gradebook file for the next school year 
you will at some point in time need to create a new gradebook file. A gradebook file contains all of your data - everything 
from courses to assignments, students and grades.  Think of these files like a word processing or spreadsheet document – a 
small, self-contained file that can be placed anywhere on your computer or network.  

● To create a new gradebook file click File › New. 

Tip:  As with many operations in this program there are usually multiple ways to accomplish any given 
task. In the case of creating a new gradebook file you could also click the  icon in the toolbar or press 
Ctrl-N.

Gradebook wizard
The gradebook wizard is started automatically to offer its assistance whenever a new gradebook is created. The wizard will 
walk you through the process of creating your courses and entering students, as well as setting up your term and category 
structures, grading scales, grading symbols, and assignment columns. The use of the wizard is optional since everything 
that the wizard does can also be done using the pull-down menus in the gradebook itself, but the wizard offers a lot of 
functionality in one easy-to-use place.

Click Next to step through the various screens of the wizard and answer its questions and fill in as much data as you can. 
You can always return to the wizard at a later time to pick up where you left off. In order to begin using your new 
gradebook you should enter at least one course and a few student names. When you're satisfied with your entries click the 
Finish button to close the wizard.

➢ Launch the Gradebook Wizard at any time by clicking Help › Gradebook Wizard

Saving your gradebook file
Once the gradebook has been created you'll want to save it. 
Just as with a word processor, changes that you make to your 
gradebook must be saved to a file in order to make them 
permanent. Click File › Save to begin the process. 

You will be prompted to select the folder location where 
you'll store the file, which might be in your "My Documents" 
folder or someplace on your file server that your network 
administrator has recommended you place files so that they 
are backed up automatically. 

Once you select the folder, enter a file name and click the 
Save button. The file name can be any valid Windows file 
name, such as "My Gradebook" or "My 6th Grade Classes".

If you try to either exit the program or open another 
gradebook file without saving the current one you will be 
asked if you want to save the changes. It is very important 
that you answer Yes unless you have a very good reason for 
discarding the changes you've made during that session.

Tip:  You should make regular backups of your gradebook file to a flash drive, CD/DVD-ROM, or by e-
mailing the file to yourself so that a copy is retained in your e-mail history.
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Creating your gradebook from Surfside Lighthouse
If your school uses the Surfside Lighthouse administrative software package and you have been granted access to the 
Teacher Client, your gradebook file can be created for you automatically, complete with all of your courses and students. 

● Login to the teacher client with your user name and password that were supplied to you by the main office.

● Click the Gradebook tab and click the Create Gradebook button.

You will be prompted for the name and location where you would like to store the file, such as in My Documents.

● Open the gradebook program and click File › Open.  Navigate to the folder where you specified the file be saved, 
open it, and verify that your courses and rosters are accurate.

Tip:  When you create a gradebook file automatically using the Teacher Client you must choose a 
semester for which rosters will be generated.  Many teachers thus prefer to start a fresh gradebook each 
semester. 

Copying your gradebook to another computer
Your gradebook file is a small document file, similar to a word processing document.  Because of this, it is very easy to 
take your gradebook home or put it on your laptop so that you can work on it while away from school.  

If you know where you saved your gradebook data file (and you should!) you can open that folder in Windows and copy it 
to a flash drive, burn it to a CD, or e-mail it to yourself.

To easily e-mail the file, you can click File › Email Gradebook.  This will launch your computer's default e-mail client and 
attach your gradebook data file to the e-mail.  If for any reason this function does not work with the way your computer is 
configured, you can e-mail the file manually as described above.

Getting to Know the Gradebook Screen
The gradebook editor is similar in design to a spreadsheet program in that you enter grades into cells that are the 
intersection of a student name row and assignment column. Final student averages are calculated automatically whenever a 
grade changes.
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Navigating around the editor

You can move the cursor around the gradebook by pressing the Up, Down, Left and Right arrow keys or by left-clicking a 
cell. Almost all data that you see - such as grades, student names or column information - can be changed by moving the 
cursor to the cell and typing a new value. Press the Enter key to accept the new value and move the cursor down to the next 
row, or press TAB to accept the new value and move the cursor across to the next column. If you make a mistake while 
typing you can press the Escape key before leaving the cell to restore its previous value. 

If you type a value that is not appropriate for the cell you're in - 
such as a grade that is not a number and is not in your symbols 
list - the original value will be restored and you'll be notified of 
the problem with a note in the status bar at the bottom of the 
screen.

Keyboard Description
Arrow keys (up, down, left, right) Navigates around the gradebook screen, from column to 

column or row to row.
Ctrl + Up arrow Moves to the top of the current column
Home Moves to the first row of the first column
End Moves to the last row of the last column
PgUp Moves up one page
PgDn Moves down one page
Escape When editing the contents of a cell, pressing Escape 

cancel that action and restores the original value.
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Keyboard Description
Tab Moves to the next column to the right
Shift-Tab Moves to the previous column to the left
Enter Accepts the current value and moves down one row
Ctrl-Z Undo the last edit (same as clicking Edit › Undo)

Getting help
There are two primary help resource screens available in the Lighthouse Gradebook.  The one you are shown will depend 
on what you activity you are performing in the program at the time of your help request.

➢ To access help, press the F1 key on your keyboard

If you are working on the main gradebook screen you will be brought to the online help system for the program.  The help 
system is organized with a list of topics on the left hand side of the screen and the contents of the topic on the right.  Click 
on a topic name to read about that topic.  An example would be a topic titled Understanding the Weighting System, which 
describes in detail how average grades are computed.

If you are on an activity window, such as adding a student or course, pressing F1 will show you a specialized help topic 
screen that explains that particular window.  The overall purpose of the window is described and each field is described. 

Toolbar and menu bar
The menu and toolbar contain all of the commands that you are able to utilize within the gradebook. The menu bar (file, 
edit, insert, etc) is a drop-down system where you click the word and a menu is displayed beneath it showing all the 
commands within that category. The toolbar beneath the menu bar contains some of the more common commands that are 
found within the menus, such as Save, Add a Student, Add an Assignment, etc.

Some commands have shortcut keys that let you press a key 
combination, such as Ctrl-S for Save. This means you hold down the 
Control key and press the letter S. If a command has a keyboard 

shortcut associated with it, the shortcut will be listed to the right of the command in the drop-down menu bar.

The toolbar can be customized to include other commands, and you can even create new toolbars in order to organize your 
frequently used commands into groups. To begin the customization process click View › Toolbars › Customize. Keyboard 
shortcuts can also be customized in a similar fashion. Customizations are saved on your computer so that they are loaded 
the next time you open the Lighthouse Gradebook program.

Course bar
The course bar lists each course you have added to your gradebook. Click 
a course name to select it, or right-click the course name to bring up a list 
of commands applicable to that course. 

The currently selected course is displayed in red while the others are in gray. There are several different ways in which the 
course name can be displayed, such as with the period, room, or teacher names. The course bar can also be displayed along 
the top, left, right, or bottom of the screen. These settings and more can be adjusted by clicking Edit › Preferences.

Columns area
The column area lists each of your assignments along with 
several pieces of standard information such as the column name, 
description, term, etc.  New columns will appear here as you add 
them to your gradebook. Only a limited number of columns can 
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fit on a single screen so it may be necessary to scroll to the left or right using the scrollbar at the bottom of the screen or the 
arrow keys. 

You can edit any piece of data for a column by clicking in a cell and either typing a new value or - in the case of the term 
and category - selecting from the drop down list. 

In addition to the standard information rows (name, description, term, category, date, weight, and possible) you can also 
display statistics about each column. Statistics include such computed values as the mean (average), minimum grade, 
maximum grade, range, variance, and standard deviation, among others. You can select which statistic rows to display by 
clicking View › Statistics.  The statistic rows that you select will be display beneath the other column information rows.

Students and grades
Student names are listed down the left hand side of the gradebook. Each line can be numbered and every two rows can be 
displayed in a different color to help identify a student's grades and average. The numbering and coloring of the names is 
optional and can be changed in the preferences screen.

Grades are listed to the right of each student under the appropriate column heading. If no grade has yet been entered for an 
assignment you'll see ** (two asterisks) indicating the missing grade.

Averages
To the far right of the gradebook are two columns: the student's numerical average and letter grade. These columns display 
the average for the currently selected term, semester or year, which can be changed via the toolbar's drop-down term 
selection menu (or by clicking View › Show Grades For). 

The average grade is calculated automatically based upon the settings you have defined.  The numerical average is a 
weighted computation of scores arrived at by examining each column's weight and possible points, then taking into account 
any category or term weighting.  The resulting numerical average is then compared against the student's grading scale and a 
letter grade is assigned. This entire process is discussed in detail in the section Understanding the Weighting System.

Tip:  There is a vast number of different ways in which teachers calculate averages. It is important that 
you read and understand the section Understanding the Weighting System to configure the program to 
meet your specific needs.  

Undo
The gradebook keeps track of every change you make.  This means you can step backwards through your most recent 
activities in order to undo a mistake. Click Edit › Undo (or press CTRL-Z) to undo the most recent change. Press it again to 
undo the change before that, and so on. If you've realized you went too far back you can click Edit › Redo to move back up 
the undo chain.

Right-click context menus
You can right-click anywhere on the gradebook screen and you'll be presented with a list of options suitable for whatever it 
is you clicked. For example, if you right-click a course tab you can perform such course-related task as editing the course, 
deleting it, adjusting its grades, or moving it to another gradebook file. 
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Right-clicking on a student's name lets you perform operations suitable to that student.  Right-clicking a selection of 
multiple grades lets you fill or adjust those grades, and so on. Making use of right-click context menus is not mandatory, as 
all of the functions contained in these menus are duplicated in the drop-down menus at the top of the screen. However, the 
context menus make using the program easier and more logical.

Multiple selections
If you click a cell while holding down the left mouse button and drag the mouse either left, right, up or down you'll create a 
selection area that encompasses one or more columns or students. Many operations will then affect that entire area, such as 
clearing a selection of grades or deleting several columns. After you select an area you can right-click inside the selection 
and you'll see a list of commands that can be performed on that selection.

Configuring your Gradebook
Each gradebook file contains one or more courses, and each course contains one or more students and assignment columns. 
Grades are entered into assignment columns in a very similar fashion to a spreadsheet program. The gradebook 
automatically computes term, semester and/or yearly averages as you enter the grades.

You must configure your gradebook correctly in order to have it compute averages the way you want them computed. 
Every teacher run their grading system in a unique way so the exact gradebook configuration will vary from teacher to 
teacher and school to school.  

The basic premise of a gradebook program is very simple:  Enter assignment grades for students in order to print reports 
and calculate averages.  However, the reality is that - in order to work with the dozens of different grading methods that 
teachers employ - you must understand column points, categories, total points method, grading scales and a handful of 
other concepts in order to ensure student averages are calculated the way that you want them to be calculated.

Tip:  Please make sure you read and understand this section of the manual, and also read Understanding 
the Weighting System, before you publish reports or submit average grades.  Do not distribute student 
averages until you are certain your calculations are working the way you want them to work.

Terms and semesters
“Terms” are analogous to marking periods and provide a way to group your column assignments 
into logical units. When a new gradebook is created a default set of terms is established 
automatically.  You can make changes to this structure as necessary.

Each assignment column that you add to the gradebook can be assigned to a term, with the end 
result being that the gradebook will then be able to compute separate term and semester averages 
even though your gradebook file may contain assignments for the entire year. Usually you'll 
define your term structure to be the same as the grading system adopted by your school. 

You can use the gradebook wizard to manage your terms or you can click View › Terms from the 
pull-down menu. You can click the Help link above the term list to view detailed information 
about each item.

➢ To view and manage your term definitions click View › Terms 

 The gradebook can display your assignments for one term, one semester, or all terms by clicking the drop-
down button on the toolbar or by clicking the View › Show Grades For menu item.  The average columns 

on the right hand side of the gradebook update to reflect whichever term is currently selected.  

Terms can be assigned a weight.  This weight can play a large part in how the student averages are calculated. You might 
want to read over Understanding the Weighting System for a thorough, yet easy-to-understand explanation of how average 
grades are computed.
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Name Semester

Q1 1

Q2 1

Exam 1 1

Q3 2

Q4 2

Exam 2 2



Tip:  It is not necessary to create a term entry for your semester averages.  It is sufficient to specify the 
semester number in the semester column so that the program can automatically compute semester 
averages based on term grades.  Do not create “Sem 1” or “Sem 2” entries in the term list.

Categories
Categories can be assigned to columns to specify the type of grades stored in that column. The use 
of categories allows you to see exactly how a student performed in each of your grading areas, 
such as homework, quizzes, and exams. Many reports will subtotal this category information and 
present category averages for your review. 

Categories can be weighted against each other to give more importance to certain grading areas. 
For example, some teacher will want quiz grades to be weighted more than homework 
assignments and exams to be weighted more than quizzes.  You can manage your categories by clicking View › Categories. 
You can click the Help link above the category list to view detailed information about each item.

➢ To view and manage your category definitions click View › Categories 

Tip:  By default, all columns are subtotaled within their respective categories, and then all of the 
category subtotals are averaged together to produce the final student averages.  If you are using 
categories only to identify the type of assignment and you do not want their use to affect the average in 
this way, you need to use  Edit › Preferences, select the Calculations tab, and choose the “alternate” 
category averaging method.

Grading symbols
Grading symbols are letter grades or words that can be recorded as scores for an assignment 
column.  Most of the time you'll enter a numerical grade for a student's assignment.  For example, 
a student might receive a 15 out of 20 possible points for a quiz.  

There are situations where it might be advantageous or necessary to record a letter grade instead of 
a numerical grade for an assignment.  Grading symbols allow you to define a letter or word that 
can be input directly as a score for an assignment.

You can manage your grading symbols by clicking View › Symbols. You can click the Help link above the symbols list to 
view detailed information about each item.

➢ To view and manage your grading symbols click View › Grading Symbols

Symbols can be notations such as Pass, Fail, Inc, or letter grades such as A, B, C. In 
order to compute the average grades, the program must be know how to turn each 
grading symbol into a numerical grade.  This is accomplished by entering the Value % 
for each grading symbol, which is the percentage of the assignment's possible points to 
award.  The program uses that percentage to figure a numerical grade for the assignment. 
That numerical grade is then used in the average grade calculation.

Tip:  You can record a symbol as a grade for an assignment in the same way 
you would a number:  by typing the symbol's letter or name and pressing the 
Enter key.
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Quiz

Homework

Exam

Default Symbols

Symbol Value %

Pass 50%

Fail 90%



Predefined grading symbols
There are 5 predefined symbols that can always be assigned as a grade, even without entering them in your Grading 
Symbols list.  This list shows each predefined symbol, its primary use, and how it will affect the student's average.

Symbol Primary Use Keyboard Average and other affects

 Positive score. Ctrl-Alt-H Affects the average if the symbol has a value defined in Preferences. 
The assignment will not show up on a missing assignment list.

 Negative score. Ctrl-Alt-S Affects the average if the symbol has a value defined in Preferences. 
The assignment will not show up on a missing assignment list.

 Assignment was turned 
in. Ctrl-C Affects the average if the symbol has a value defined in Preferences. 

The assignment will not show up on a missing assignment list.

 Assignment was not 
turned in Ctrl-X Affects the average if the symbol has a value defined in Preferences. 

The assignment will not show up on a missing assignment list.

NC No Credit - Assignment 
not turned in Ctrl-Alt-N The grade is considered equal to 0 points earned, and will be averaged 

as such.  The assignment will show up on a missing assignment list. 

Aside from NC (which is always a 0), each of the other symbols can be configured to be included in or omitted from the 
student's average.  To set how each symbol is defined, click Edit › Preferences, click the Calculations tab, and set the 
symbols' “value %” number.  If you leave the value blank, the symbol will not be included in the average grade calculation. 
Values should be entered as a percentage of the total possible points for an assignment (i.e. 70=70%).

Tip:  With the exception of NC, entering a grading symbol as a score (either a predefined symbol or one 
you create) will  prevent that assignment from showing up on the student's Missing Assignment report.

Grading scales
Grading scales convert a numerical average into a letter grade.  Term, semester and final averages are first calculated in 
numerical form, and those averages are then compared to the each student's grading scale to derive a letter grade.  A 
grading scale is simply a set of cutoff values where each letter grade starts.  Any numerical average grade equal to or above 
that cutoff and below the next highest cutoff will be assigned that letter grade.

You can manage your grading scales by clicking View › Grading Scales. You can click the Help link above the scales list to 
view detailed information about each item.

➢ To view and manage your grading scales click  View › Grading Scales

For example, an "A-F" grading system might be defined as follows: F=0 to 65, D=65 to 70, C=70 to 80, B=80 to 90, A=90 
to 100. When creating a grading scale you define each letter grade and its lower bound breakpoint.  This grading scale's 
cutoffs would be:  F=0, D=65, C=70, B=80, A=90.

You can define up to 10 grading scales, and each student can be assigned a different scale. It is possible, for example, to 
specify some students in a class as belonging to the “A-F” scale, while other belong to an "OSNU" (outstanding, 
satisfactory, not-satisfactory, and unsatisfactory) scale.

➢ The default grading scale for each student in a course is Scale 1.  To change a student's grading scale, right-click 
the student's name, click Edit Student, and select the desired grading scale from the dropdown list. 
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Tip:  You can also create or modify your grading scales using the Gradebook Wizard.  Click Help ›  
Gradebook Wizard to launch the wizard, then click the Scales & Symbols tab.  The wizard may make 
creating your grading scales easier as it has buttons you can click to create standard grading scales. 

Preferences
There are many settings in your gradebook program that affect how the program behaves.  These settings range from what 
you see on the screen such as fonts and colors, to changing the way average grades are calculated.  

➢ To modify your program settings, click Edit › Preferences

The preferences screen is organized in a tab format, with tabs for General, User Interface, Calculations, Protection and 
Terminology.  This section of the manual will discuss the more important of these settings.  For a complete description of 
every preference setting, click the Help link on the preferences screen.

General School name
This is the name of your school as it will appear at the top of all reports.

Number of undo levels
This option represents the maximum number of times you can choose the Undo option 
(Edit › Undo) to back out of a mistake you have made. For most users 20 is a sufficient 
escape margin but you are free to increase or decrease this number as you see fit.

Automatically open last active database 
This option automatically retrieves the last gradebook file that was open when you last 
exited your software.

User Interface This tab contains settings that affect how your gradebook looks.  While many of the options 
are important, none of them affect the outcome of student averages or grades and as such will 
not be discussed here.  Refer to the online help system by clicking the Help link on the 
preferences screen.

Calculations Number of decimal places in the average grade (default is 2)
This setting control the number of decimal places for average grades.  If you set it to 2 
places, you'll see averages like 93.45.  If you set it to 0 places, you'll see averages like 90.

Default number of points for a newly added column (default is 100)
Rather than forcing you to type the number of points carried by each new assignment, you 
may set a default value. Most teachers grade on the 100-point system, so that's the default 
our programmers chose. You may change this to whatever you wish it to be. No matter 
how you set this option, you can always change the definition when you add a new 
column to your gradebook.

Category averaging method
Standard averaging means that the use of categories affects the average, because all 
assignments within a category are first subtotaled, and then all the category subtotals are 
averaged together to produce the term average.

Alternate averaging used categories only to specify the type of an assignment, but the 
subcategory grades are not subtotaled and thus do not affect the term average.

Protection Using the Protection tab you can put a password on your gradebook file so that your data 
cannot be viewed with a standard text editor.  When you attempt to open a password protected 
gradebook file, you will be prompted for a password each time.

Terminology The Terminology tab lets you change the words used to describe several key program items. 
For example, we refer to “columns”, “courses” and “categories”.  You may prefer 
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“assignment”, “subject” and “bin”.

Courses and Students

Adding courses
Each course tab contains a roster of students in your class, as well as its own set of assignment columns for which grades 
can be entered.   You should add one course tab for each section of a course you teach.  You can use the gradebook wizard 
(Help › Gradebook Wizard) to add your courses or you can click Insert › Course from the pull-down menu.

➢ To add a new course click Insert › Course 

When adding a new course, the course name is the only mandatory piece of information but the other fields have the 
following uses:

● The Teacher Name and Period are printed on most reports and can also be shown on the course tabs

● The Section, Teacher ID and Room are used to help match students when submitting averages electronically to a 
student information system such as Lighthouse.

Tip:  If your gradebook was created for you automatically by the Surfside Lighthouse Teacher Client 
you will likely not have to add any new course tabs manually.

Adding students
Within each course tab is maintained a roster of students enrolled in the class. Each course has its own separate roster, so 
adding, editing or removing students from one course does not affect any other course. 

A student must be added to the course roster before you may 
enter grades for that student. As with your course definitions, 
you can use the gradebook wizard to add your students or you 
can click Insert › Student from the pull-down menu. To edit a 
student, right-click the student's name and click Edit Student.

➢ To add a new student click  Insert › Student

The student's name is the only mandatory piece of information 
you must enter. The rest of the student fields are optional and 
are used either for reporting or to help match students when 
submitting averages electronically to a student information 
system. 

Even if you are using a student information system such as 
Surfside Lighthouse that has prepared your gradebook for you, 
student adds and drops throughout the year must be edited 
manually into your gradebook.  There is not a direct link 
between your gradebook and the main office, so changes the 
office makes to student schedules do not show up in your gradebook, and vice versa.  The Student ID # and Birthdate are 
particularly important fields.  These two fields are the primary determining factor used to match students between your 
gradebook and the office's database, so make sure to enter them accurately.

A special mention must be made to the Grading Scale field.  While grading scales have not yet been presented, a grading 
scale defines the numerical breakpoint where each of your letter grades starts.  For example, 90=A, 80=B, etc.  Each 
student within a course can have his or her own unique grading scale.  This is important because it allows a subset of 
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students in the same class to use a completely different grading system.  A complete discussion can be found in the section 
entitled Grading Scales.

You can click the Help link on the student screen to view detailed information about each item on the student screen.

Tip: For sorting purposes we recommend that you enter student names in a Last Name, First Name 
format. 

Dropping students
If a student drops from your course, you have the option of deleting the student or dropping the student.  Deleting the 
student will erase the student and all grades associated with that student completely from your gradebook.  Dropping the 
student preserves the existing grades for the student but prevents that student from receiving a final average and from 
showing up on reports.

➢ To drop a student, right click the student's name and click Drop Student

➢ To delete a student, right click the student's name and click Delete Student

Tip:  If a student attended your class and received any grades, we recommended that you drop the 
student rather than delete her.  This will preserve her grades for future reference.

Changing a student's record
A student's record contains some basic demographic information, such as birth date, gender, address, and phone numbers. 
Most of the field are for your reference purposes only and needn't be used unless you require them.

➢ To edit a student's record, right click the student's name and click Edit Student.

If your gradebook was created for you automatically by the Surfside Lighthouse Teacher Client, much of this student 
information may already be filled in for you.  You may change any piece of information, and that change will affect your 
gradebook only.  None of your changes will be sent back to the main school database.

Several student fields are very important and care should be taken when changing the data.  

● Student Name – Usually entered as Last Name, First Name, the student's name will show up on just about every 
report.  When sending average grades back to a student information system, the student's name will be used in the 
absence of a Student ID # when matching students to the main school database.  If your gradebook file was created 
for you automatically, do not change the student's name unless you have a good reason.

● Student ID # - The Student ID # is used to match your students to those in the school's main database when 
automatically submitting average grades.  You should not change this number for existing students without a very 
good reason.  For new students joining your class after the gradebook is initially created, enter the student ID# 
exactly as it was supplied to you.  Failure to enter a correct ID# may affect the accuracy of the term averages you 
submit back to the school system.

● Birthdate – The date of birth may be used to match your students to those in the school's main database. 
Specifically, if your student has a birth date that is different from the one stored in the main database, the matching 
system may not think it's the correct student.  Do not change this date for existing students, and for new students 
ensure that the birth date is entered correctly.  

● Grading Scale – Within each course, every student is assigned to a grading scale.  By default, Scale 1 is used for 
all student in the course unless changed.  Changing a student's grading scale may affect the resulting letter grades 
derived from that student's average grade, so make sure you have verified the settings for your grading scales 
before changing this value. 
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Sorting students
Students can be displayed in your gradebook sorted in a particular order.  By default the students are arranged 
alphabetically from A to Z, but you can change this order.  In addition to sorting by student name, you can also sort 
students based on their score for any assignment.

➢ To sort students alphabetically right-click the student name column and choose one of the Sort Students selections 
to sort either in ascending or descending order.

➢ To sort students based on the grades received for a particular assignment, right-click anywhere in the column and 
choose one of the Sort Scores selections to sort either in ascending or descending order.

Entering Grades

Adding columns
Columns contain quiz, test, exam, homework and any other grade that you want to track as part of a student's progress in 
your course. In fact, all grades that you enter into your gradebook will belong to a column. Columns are specific to each 
course, meaning that each of your courses has its own set of assignment columns for which to enter grades. To add a new 
column click Insert › Column. You can click the Help link above the scales list to view detailed information about each 
item.

➢ To add a new column to your gradebook click  Insert ›  
Column

Each column has several fields which together control how that 
column behaves in your gradebook.  For each column it is important 
that you correctly specify each field's value, as several of them can 
drastically affect the grading calculations.

Column Name - The column name is displayed at the head 
of the column when you're working in the gradebook and is 
printed on many reports. As the gradebook screen can only 
display so many characters at a time, the column name should be as short as possible so that you can understand 
the column's contents even when viewing only the first several characters. We recommend a column name that is 
no longer than 6-8 characters. 

Column Description - The description is a longer explanation of the column's meaning and also appears on many 
reports.  While the column name should be kept very short (6-8 characters) the description can be any length. 
However, because the description also appears on many reports, verbosity can cause some reports to look 
cluttered.

Term – The term (marking period) to which the assignment belongs.  You should always specify a marking period 
so that the column is included in the appropriate term average. 

Category –  The use of categories allows you to see exactly how a student performed in each of your grading 
areas, such as homework, quizzes, and exams.  Because the use of categories can drastically affect your averages, 
you should read Understanding the Weighting System before using categories. 

Date - The date refers to the date that the grades in the column were due or assigned. Printed reports usually list 
the most recent assignments first, and the gradebook screen itself can also be sorted by date. There are no 
restrictions on the format of the date you use, so it's acceptable to enter dates in "8-15-06", "8/15/2006", or any 
other format you choose. It's best to be consistent in the format you use so that reports look better. It is not 
absolutely necessary to enter a date for a column, but you'll lose the ability to sort your gradebook on the date of 
the assignment and on printed reports you'll not see the date of missing work.

Weight - Columns can be weighted against one another, relative to other columns within the same category, term 
or semester. For example, if you want all of your homework assignments to be weighted equally then you would 
either leave the weight at 0 or assign them all the same weight.  If you have a particular homework that is a double 
assignment, you would give that assignment twice the weight as the others.  If you assign a weight to even one 
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column then you should assign a weight to them all so that it is clear exactly how the final average is computed. 
When using a Total Points method of grade calculations (as discussed in Understanding the Weighting System) the 
weight and possible points should contain the same value.

Possible Points - The possible points is the total number of points that a student can receive for that assignment. 
For example, a quiz might have 10 and a standard test might have 100. The student's percentage for a given 
column is calculated as Grade / PossiblePoints * 100. Therefore, all other things being equal, a value of 9 in a quiz 
worth 10 is the same as a value of 90 in a test worth 100 when figured into the average. If the number of possible 
points is zero then the column will not be included in the average.  When using a Total Points method of grade 
calculations (as discussed in Understanding the Weighting System) the weight and possible points should contain 
the same vale. 

Entering grades
Grades are entered at the intersection of a student row and assignment column. Select the desired cell by left-clicking the 
mouse or using the arrow keys, and then type a numerical value or the name of a pre-defined symbol into that cell. Press 
the Enter key to accept the grade and move to the next student or press the Tab key to accept the grade and move to the 
next column. If you want to edit an existing value instead of typing a new one then double-click the cell to go into edit 
mode.

To delete a grade, select the cell and either press the Del key or type an asterisk (*). An asterisk is considered a no-grade 
symbol and indicates that the student is missing a grade for that assignment column. Missing grades do not count for or 
against the student are a completely omitted from the average grade calculation.

Tip:  As you add, change, or delete grades the students' averages will be updated automatically to reflect 
the new grades.  

Extra credit columns
When you add a new column to your gradebook it does not affect a student's average until you enter a grade for that 
assignment.  That is because each cell in a new column has a default grade of **, which does not factor into the average. 
What this means is that any column can be treated like an extra credit assignment simply by leaving the grade blank for 
those students who do not turn in the assignment.  If a grade is entered it will be factored into the average, and if a grade 
not entered it will not affect the average.

Tip:  Lighthouse Gradebook does not support a “help but not hurt” extra credit system.  This means that 
if you enter a grade for a column it will be factored into the student's average even if it brings the 
average down.  Should you need to apply logic to an extra credit column that says to only factor a grade 
should it help the student, you'll have to perform that step by manually deleting the offending grade 
from the extra credit column.

Sorting columns
As you add new columns to your gradebook they are added as the rightmost column in your gradebook.  That is unless you 
have specified a column sorting setting, in which case the column will be positioned according to your sort settings.  You 
can sort your columns by name, date, category, weight, and possible points.  

➢ To sort your gradebook columns click View › Sort Columns and select one of the sorting methods.

For the most part, sorting the columns only affects the screen display and not printed reports.  Most reports list assignments 
in date order.
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Tip:  You can remove column sorting from your gradebook and return the columns to their originally 
entered order by selecting Unsorted from the column sorting options.

Filling grades
Usually you will enter grades for an assignment one student at a time.  However there are times when it is faster or easier to 
fill an entire assignment with a single grade, and then go back and make changes to those students who have a different 
grade.

➢ To fill grades for an assignment, right click anywhere in the column and click Fill Column.  Type a numerical 
grade or symbol to fill and click the Ok button.

When filling a column you can choose whether to fill a grade for every student or for only those students who are missing a 
grade.  If it's a new assignment that you are filling the choice will not matter, but if it's one that already has grades you 
must make sure to not accidentally erase your grades.  If you do make a mistake, click Edit › Undo and try again.

Tip:  You can also fill a student, a selection, or even an entire course with a grade.  Clicking the right 
mouse button on a student's name, a course tab, or a selection of grades will allow you to select that 
object's Fill function.

Adjusting grades
You can adjust grades for an entire assignment, such as to add a certain number of points to a test or adding a percentage to 
each student's grade.  Adjusting grades can be useful when you need to rescale a test or quiz.

➢ To adjust grades for an assignment, right click anywhere in the column and click Adjust Column.  Type an 
adjustment amount, specify how the amount will affect the existing grades (add or subtract a value or percentage), 
and click the Ok button.

Override a student's average grade
Student averages are calculated automatically whenever you add, change or delete grades.  Your gradebook can calculate 
term, semester and yearly averages and you control the way that average is determined as described in Understanding the 
Weighting System.  

You will usually want to let the program calculate your averages automatically, but there are times when you might want to 
override this calculation in order to consider factors such as class participation, improvement, or other subjective concerns. 
To do so, click to select the average grade you wish to override in the far-right grade column and then type the new letter 
grade.  The newly entered grade will be underlined to indicate that it is an override.

When you have created an override for a student, changes you make to that student's grades will not affect his average.  In 
order to remove the override and revert that student to using the automatic calculation, select the overridden grade and 
press the Delete button. 

Tip:  If you find that you are entering manual overrides for a large majority of your students you may 
want to look at how you have configured the program to calculate your averages and make adjustments 
as necessary.
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Understanding the Weighting System
At the simplest level the student's average is be the sum of all the grades in your gradebook, divided by the total number of 
grades. However, that wouldn't allow you to produce separate term and semester averages or to specify that exams count 
more toward the average than homework assignments. For these and other such tasks you need to turn to the weighting and 
grouping systems provided in Lighthouse Gradebook.

Attention:  It is very important that you read and understand the weighting and grouping system before 
you publish any grades or submit any averages.  There are many ways that teachers calculate averages. 
You must configure the program properly in order to produce the results that you need.  Lighthouse 
Gradebook computes averages exactly as you have instructed it.  If your instructions are incorrect, the 
averages will be incorrect.

Grouping
There are three levels of grouping that you can use: categories, terms and semesters. Before going on to discuss the 
weighting system it is important to understand how these groupings affect the student averages.

When computing averages, each category is subtotaled within each term to produce a category average. Each of these 
category subtotals is then averaged with the other category subtotals to produce a term average.

((Category 1 subtotal) + (Category 2 subtotal) + (Category 3 subtotal)) / 3 = Term Average

Consider this simple example of category grouping: A student has five columns all within the same term. Four of the 
columns are assigned to a Homework category and each has a grade value of 80. The last column is assigned to an Exam 
category and has a grade value of 90. 

● Without grouping, this student's term average is: (80+80+80+80+90) / 5 = 82. 

● With grouping the average is: (80+80+80+80) / 4=80.  (80 + 90) / 2 = 85. 

This is a very important concept to understand, as it can have a profound impact on your averages.  If you are using 
categories only to show each column's type but do not want this subtotaling and grouping to occur, you must change to the 
“alternate” category averaging method in Preferences.

The same grouping principle applies when calculating a semester average.  Subtotals are first generated for each term and 
then averaged together to produce the semester average. Finally, the semester subtotals are averaged to produce a final year 
average.

((Term 1 subtotal) + (Term 2 subtotal)) / 2 = Semester Average

Weighting
The weighting system allows you to count more heavily one assignment, category subtotal or term subtotal over another. 
Through the use of weighting you can tell the program that you want Exams to count more towards the term average than 
Homework, or that you want Q1 and Q2 to count twice as much as the semester Exam grade.

There are 3 types of weighting:  column, category, and term.
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Column weighting
Each assignment column has a “weight” line, which is where you can specify how that column's grades relate to the other 
columns within that category.  If you leave the weight line at 0 (the default) then all columns within that category will be 
treated equally.  If you want one assignment to count more than another, 
you can enter a weight for the assignment that is proportionally more than 
the other assignments in that category.   Each assignment will then be 
weighted based on how the assignment's weight relates to the other 
columns.    

➢ To weight an assignment, enter a number into the column's 
“weight” line

There are three important points to remember when using column 
weighting:

1. Column weighting applies only to columns within the same category.  This means that weights within the 
“homework” category will not be factored against weights in the “tests” category.  (Note:  If you are using the 
“alternate” category averaging method then categories are effectively ignored from all average grade 
calculations.  In that case, each column's weight will be compared to all other columns, regardless of  the 
category to which they are assigned.  This means that if you give one quiz a weight of 2 and all other assignments 
– even exams – a weight of 1, the quiz will count twice as much as any other assignment.)

2. If you assign a weight greater than zero to any column, then you must assign a weight to all columns within the 
same category.  Failure to do so will cause all columns with a weight of 0 to be excluded from the average.

3. A column's weight value is proportion to those in the other columns.  For example, if you want Quiz1 to be 
counted twice as much as Quiz2, enter a value for Quiz1 that is twice as much as the value for Quiz2.  You could 
use 2 and 1, 4 and 2, or 100 and 50.  So long as you are consistent in your use of weights the actual numbers used 
don't matter, only their relation to the other columns.

Tip:  If you find that you are assigning the same weight to all assignments within a given category, such 
as all Tests with a weight of 2, then you might be better served using category weighting instead of 
column weighting.

Category weighting 
Each category that you create can be assigned a weight.  When calculating averages each category is subtotaled and 
averaged together with all the other category subtotals.  By using weights you can specify exactly how much each category 
is figured into the term average.   

➢ To weight your categories, click View › Categories.

There are two important points to remember when using category weighting:

1. If you assign a weight greater than zero to any category, then you should assign a weight to all categories so that it 
is clear exactly how each category subtotal affects the average grade.

2. A categories weight is proportion to those from other categories.  For example, if you want Tests to be counted 
twice as much as Quizzes, enter a value for Tests that is twice as much as the value for Quizzes.  You could use 2 
and 1, 4 and 2, or 100 and 50.  So long as you are consistent in your use of weights the actual numbers used don't 
matter, only their relation to the other categories.  It may be convenient to have all of your category weights add up 
to 100.
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Note:  If you are using the “alternate” category averaging method as defined in Preferences, then 
categories are effectively ignored in the average grade calculation and any weights you enter will be 
discarded. 

Term weighting
Each of your terms (also called marking periods) can be weighted in order to compute a semester average.  Without 
weighting the semester average is each term's subtotal divided by the number of terms.  With weighting you can, for 
example, indicate that term 1 and term 2 should have equal weight and count for 80% of the semester, while the mid-term 
exam counts for 20%. 

➢ To weight your terms, click View › Terms and Semesters.

 There are two important points to remember when using term weighting:

1. If you assign a weight greater than zero to any term, then you should assign a weight to all terms so that it is clear 
exactly how each terms subtotal affects the semester average.

2. A terms weight is proportion to those from other terms.  For example, if you want Term 1 and Term 2 to be 
counted twice as much as the Mid-Term Exam, enter a value for Term 1 and Term 2 that is twice as much as the 
value for Mid-Term Exam.  You could use 2/2/1, 4/4/2, or 40/40/20.  So long as you are consistent in your use of 
weights the actual numbers used don't matter, only their relation to the other terms.  It may be convenient to have 
all of your term weights add up to 100.

Tip:  You can have the program tell you exactly how it is calculating a student's average by printing the 
Explain Student's Average report.  This report is invaluable in diagnosing discrepancies between your 
personal calculation method and the one you told the program to use.

Averaging methods
There are many ways in which teachers compute their averages - so many that it's not possible just to choose your 
averaging method from a list and have the program adjust itself accordingly.  Instead, you will tell the program how you 
want the averages calculated through the use of column weighting, categories, and a few preference settings.

If you have not yet read through the rest of this Understanding the Weighting System section of the manual we suggest you 
do so.  It contains very import information that you need to know in order to have the program calculate accurate averages 
the way that you want them calculated.  

Following are several of the more popular types of averaging systems, with an explanation on how to configure your 
gradebook to use that system.  These should be used a guide in setting up your own gradebook.
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Method name Standard with categories

Description The standard with categories method uses categories to subtotal all assignments within each 
category, and then each category's subtotals are averaged together to produce a term average. 
Each assignment is treated equally within its respective category, with the student's grade 
being calculated as a percentage of 100%

Steps 1. In Edit ›  Preferences, click the Calculations tab and set the category averaging method to 
Standard

2. Create your category names and weights using View ›  Categories.  The use of weights is 
optional, but if you assign weights then the term average will be a weighted average of all the 
category subtotals.

● For each assignment you create:

1. Be sure to assign a category to every assignment.

2. Student grades for the assignment will be factored as a percentage of the Possible 
Points.  For example, an 8 out of 10 possible equals 80%.  This 80% will be averaged 
with the other columns within the category.

3. Enter a Weight of 0 for all assignments unless you really need the ability to weight 
one column within a given category more than another.  If you enter a weight for one 
assignment then you will need to enter a weight for any other assignments within the 
same category that you want included in the average grade.  Once a single weight is 
entered, any assignment within the same category with a 0 weight will be ignored 
when calculating the average grade.

Method name Standard  without categories

Description The standard without categories method uses categories only to designate the type of each 
assignment - but does not permit category subtotals to affect the term averages.  Each 
assignment is treated equally across the entire term.  Only column weighting will cause one 
assignment to count more than another.

Steps In Edit ›  Preferences, click the Calculations tab and set the category averaging method to 
Alternate

Create your category names and weights using View ›  Categories.  The category weight is 
ignored in the average grade calculation, but it's best to set each weight to 0 to avoid 
confusion.

For each assignment you create:

1. Assign a category to an assignment only if desired.  Since the use of categories do not  
affect the average grade it does not hurt to use categories for some assignments but 
not others.

2. Student grades for the assignment will be factored as a percentage of the Possible 
Points.  For example, an 8 out of 10 possible equals 80%.  This 80% will be averaged 
with all the other columns within the entire term.

3. Enter a Weight of 0 for all assignments unless you really need the ability to weight 
one column more than another.  If you enter a weight for one assignment then you will 
need to enter a weight for any other assignment that you want included in the average 
grade.  Once a single weight is entered, any assignment with a 0 weight will be 
ignored when calculating the average grade.
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Method name Total points method with categories

Description The total points with categories method has each assignment valued at a certain number of 
points.  Each grade a student receives for an assignment is added to his total, and the final 
average is the total received divided by the total possible.  This method uses categories, so all 
assignments within each category are added up and subtotaled, and then divided by the total 
number of categories to produce the term average.

Steps In Edit ›  Preferences, click the Calculations tab and set the category averaging method to 
Standard

Create your category names and weights using View ›  Categories.  The use of weights is 
optional, but if you assign weights then the term average will be a weighted average of all the 
category subtotals.

For each assignment you create:

1. Be sure to assign a category to every assignment.

2. Enter the possible points for the assignment.  Student grades for the assignment will 
be added to all other assignments within the same category.  The category subtotal 
will then be the total points received divided by the total number possible.  Example: 
8 of 10 and 7 of 10 equals 15 of 20, or 75% for the homework category.

3. Enter a Weight equal to the number of Possible Points.  While not usually thought of 
as weighting, a total points method is nothing more than treating (or weighting) one 
column more or less than another.

Method name Total points method without categories

Description The total points without categories method has each assignment being valued at a certain 
number of points.  Each grade a student receives for an assignment is added to his total, and 
the final average is the total received divided by the total possible.   This method uses 
categories only to designate the type of each assignment, but does not use category subtotals to 
affect the term averages

Steps In Edit ›  Preferences, click the Calculations tab and set the category averaging method to 
Alternate

Create your category names and weights using View ›  Categories.  The category weight is 
ignored in the average grade calculation, but it's best to set each weight to 0 to avoid 
confusion.

For each assignment you create:

1. Assign a category to an assignment if desired.  Since the use of categories do not 
affect the average grade it does not hurt to use categories for some assignments but 
not others.

2. Enter the possible points for the assignment.  Student grades for the assignment will 
be added to all other assignments across the entire term.  The term average will be the 
total points received divided by the total points possible.  Example:  8 of 10 and 7 of 
10 equals 15 of 20, or 75%.

3. Enter a Weight equal to the number of Possible Points.  While not usually thought of 
as weighting, a total points method is nothing more than treating (or weighting) one 
column more or less than another.
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Explain student's average report
The Explain Student's Average report is designed to assist you in understanding exactly how the program has computed a 
student's term or semester average.  If you find that the program's average does not agree with your calculations, this can be 
an invaluable tool in diagnosing the problem.

➢ To run the average explanation report, click Reports › Explain Student's Average

The average grade explanation shown in Figure 1 is for a very simple average grade calculation in which a student received 
grades in two columns within the Quiz category for Term Q1.  The grades are 90 and 100.

As you follow from the top to bottom, notice the indenting of each section of the report.  The indenting shows that a new 
subtotal section has been started - such as a semester, term or category grouping.  In this example, the two grades are 
shown at the bottom under the Quiz category.  The Quiz line prints the total points for all grades in that category and 
divides by the number of grades to produce a Quiz category subtotal of 95.00.  This being a very simple example there are 
no grades in any other category or term, so the 95.00 average is raised upwards through each subsequent level of grouping 
– term, semester and finally year.

In Figure 2, we've added a grade of 85 to the Homework category.  In this example, the Quiz category is weighted at 40% 
and the Homework category at 20% (an unused Exam category is weighted at 40% for a total of 100% across all 
categories).  A “standard” category method is in effect here, which means that the use of categories does affect the average 
grade calculation.

Once again looking at the indentation shows the various levels of grouping.  The furthest indented lines are the grades 
themselves.  Each category subtotals its own grades to derive a category average.  In this case, the Quiz category subtotals 
to 95 and the Homework category subtotals to 85.

Since in this example the categories are weighted as 40% and 20%, the term average is not a simple average of the two 
category subtotals.  That would not take the weighting into account.  Instead what happens is that each category subtotal is 
multiplied by its weight to produce a weighted subtotal.  The weighted subtotals are then divided by the total weight to 
produce a term average.  If you look at the “Term Q1” line you'll notice a value of 5500 / 60.
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In this example, the Quiz category is weighted at 40% so we multiply 95 * 40 = 3800.  The Homework category is 
weighted at 20% so we multiply 85 * 20 = 1700.  The total of the weighted category subtotals is 3800 + 1700 = 5500.  This 
number is divided by the total of all category weights, in this case 40 + 20 = 60.  5500 / 60 = 91.68, which is our final 
average.

Both of these examples are fairly simple in that there are not many grades and all of the grades are assigned to the same 
term.  However, even when printing an explanation for a student with a complete set of yearly grades all of the same 
principles apply, and if you step through each level of subtotals you can figure out exactly how you've instructed the 
program to calculate your averages.

Reports
Lighthouse Gradebook offers many reports that contain different views of your data. All reports share a common interface 
that lets you zoom in and out, scroll, change the report settings and layout, print or e-mail the report, and other tasks.

To produce a report click the Reports menu and select the desired report from the drop-down menu.

Navigating the preview screen

The navigation bar across the top shows you the current page and total number of pages in a Current/Total Pages format. 
You can click the left and right arrows to move forward and backwards through the pages in your document, or directly to 
the beginning and end. If there is only one page in the document these buttons will be dimmed and not available (as shown 
above).

The magnifying glass controls the zoom, which lets you move in to see a bigger view of the document or zoom out to see 
more of the page. Clicking the magnifying glass once will zoom to 100% scale, which is actual size. Clicking it again will 
zoom to "whole page" which lets you see the layout of the entire page, usually at the expense of not being able to read the 
text. You can click the down arrow button next to the magnifying glass to select from a few preset zoom levels. You can 
also double-left click anywhere in the document to zoom in, or double-right click to zoom out.
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If the entire page does not fit within the current window then scroll bars will appear on the right hand side of the page 
and/or at the bottom. Use these scroll bars to uncover areas of the document that you can't see. You can also click and hold 
the mouse button anywhere in the document and drag the mouse to scroll.

Common report tasks
Every report screen has the same set of common tasks that let you interact with the report in various ways:

Print this report - Sends the report to the printer. After clicking this link a standard Windows Print dialog will be shown 
that lets you select the destination printer as well as adjust certain printer settings. The exact settings that you can change - 
and even the look of the print dialog screen - will depend on your version of Windows and the type of printer you're using. 
But in most cases you can at least select the pages to print, the number of copies, and the page orientation (portrait or 
landscape).

Save to PDF file - Saves the entire document to an Adobe Acrobat (PDF) file. PDF files are industry standard files that can 
be shared with other users. All that is required in order to view a PDF file is a free piece of software called Acrobat Reader 
which is available on Adobe's website.

Email report - The option first automatically saves the report to a PDF file, then launches your e-mail client (such as 
Outlook) and attaches the report file. If for any reason the program is not able to locate your e-mail client software to 
automate this process you can still save the file to a PDF and e-mail the file yourself. 

Change report settings - Each report can be customized in 
various ways, from wording to colors, fonts, and content. The 
options are grouped together with each other so that it's easy to 
locate those in which you are interested. The groupings are 
Captions, Colors, Content (not shown), Font (not shown) and 
General (not shown). Clicking any item displays at the bottom 
of the window a short explanation of what it does.

As you make change to the various settings the report will be 
automatically updated to reflect the new values. Usually the 
update takes place immediately letting you get instant feedback 
about how the report will look, but if the report takes a long 
time to generate it will not be redrawn with your changes until 
you click the Close button.

When making changes to colors, fonts and yes/no values you 
can double-click the item to change its value.

Reset report defaults - Any changes that you make to the 
report settings will be saved along with the gradebook file and 
applied the next time you produce the report. This is usually a 
good thing and allows you to customize your reports to your 
liking and use that format throughout the year. However, if for 
any reason you want to revert back to the default layout then 
click this link.

Page setup - This launches the printer's page setup dialog that 
typically lets you adjust the paper size and source, page 
orientation (portrait or landscape) and margins. The exact 
settings that you can change will depend on your version of 
Windows and the type of printer you're using. Any changes that you make in the page setup dialog will be saved along with 
the gradebook and reapplied the next time you produce the report.

Close report - Closes the report preview and brings you back to your gradebook screen.
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Student selection
When you select a student-based report, only the currently selected student in your gradebook will be processed. If you 
want to include all students or select certain students then you can click the All Students and Choose Students links, 
respectively. Clicking the One Student link will always revert back to the student that is currently selected in the 
gradebook.

Term selection
Certain reports gather their data from one or more terms (marking periods) or semesters. This data might be column scores, 
missing assignments, or averages. The currently selected term or semester being viewed in your gradebook will be used 
when producing a new report, but you can select a different one if desired. The report itself will always in some way 
indicate from where it is gathering its data with wording such as "Final Average" or "Q1 Grade". 

Progress report
The progress report is designed to show an individual student's performance in your class.  Printed is the term or semester 
average, any missing work, that student's rank in the class, and information about the most recent assignments.  Each 
category is subtotaled at the bottom of the report, and your grading scale is printed in order to explain the number to letter 
conversion.

This report only prints on a single page.  If you need to print more assignments than will fit on a single page, use the Scores 
report.

Scores
The scores report is designed to show all of an individual student's assignment grades in your course.  Printed is the term or 
semester average, any missing work, that student's rank in the class, and all assignments.  

Missing assignments
The missing assignments report is designed to show a list of any missing assignments for an individual student.  Printed is 
the term or semester average, a list of the most recent completed assignments, that student's rank in the class, and a list of 
all the missing assignments.

Assignment report
The assignment report is designed to show the details of an individual assignment.  Printed is the basic assignment 
information (name, category, term, date, and possible points), statistics (average, min, max, etc), students who have not 
completed the assignment, a breakdown of grades, and the scores for each student.

Class summary
The class summary report is designed to show each students' current progress in your course.  Printed is some basic course 
statistics, a break of grades, and the term average for each student.

Spreadsheet of columns
The spreadsheet report is designed to print your gradebook in a manner similar to what you see on your screen.  Printed is a 
column for each assignment, and each student shows all assignment grades plus the term, semester, or final average.

Explain student's average
The explain averages report is designed to assist you in understanding exactly how the program has computed a student's 
term or semester average.  There are many ways in which averages can be calculated, and for a complete explanation of all 
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those options you should read Understanding the Weighting System.  If you find that the gradebook program's average does 
not agree with yours, this can be an invaluable tool in diagnosing the problem.

Sending averages to Surfside Lighthouse
If you have licensed your copy of Lighthouse Gradebook then you can submit your term or semester averages back to the 
Surfside Lighthouse Teacher Client in order to help speed entry of grades to the office.

Your gradebook program may be located on your school computer, your laptop, or maybe on your home computer. 
Because of this flexibility it is not possible for the Lighthouse Teacher Client to directly read your gradebook file and 
extract the student averages.

Instead, you will create an “averages file” that contains student 
averages in a standard format that the Lighthouse Teacher Client 
can understand.  Once the file has been created, you can then bring 
that file to your computer at school and use the gradebook tab of 
the Teacher Client to import the averages file.

➢ To create your averages file that will be sent to 
Lighthouse, click File › Save Averages for Student System

You must specify which term or semester averages you want to 
submit to Surfside Lighthouse, and then click the Select button to 
specify where the “averages file” will be placed.  A good place to 
save this file is on your Desktop with a name of “Averages”.

Uploading grades to MyStudentData.com
If your school subscribes to Surfside's MyStudentData.com Internet student data access service you may be able to upload 
your grades to the website so that parents and students can view the grades securely from from their home computer.  

➢ To upload grades to MyStudentData.com, click File › Upload to MyStudentData.com

You will be required to enter a username and password, which will be 
supplied to you by your school's administration.  The first time you login you 
will be required to create a PIN number.  This PIN number can be any number 
3 or more characters in length.  The PIN will ensure that no other teacher can 
affect the grades you have uploaded.  Click the Login button to attempt to 
login to the website.  Any errors will be reported at the bottom of the screen.

Once logged in, specify the term and courses to upload and click the Begin 
Upload button.  
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