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Lighthouse Gradebook

Introduction
The Lighthouse Gradebook is  a program designed to  emulate  a standard pen-and-
paper gradebook to track student grades across an entire school year.  Because the 
program uses an industry standard look and feel teachers can start using the program 
immediately and be proficient in a very short time. Powerful tools are available to 
track a student's performance and produce professional quality reports quickly and 
easily.

Many screens throughout  the program offer  a  Help button that  provides you  with 
detailed instructions on that specific screen. By clicking the Help button you will be 
able to read a topic covering all of the elements you see on that screen, as well as 
discussing some key concepts related to what you're currently working on.

For more general help press the F1 key from anywhere in the program and you will be 
brought to the on-line help system. Using the navigation pane on the left hand side of 
the screen you can look for help topics, browse the index, or search for specific words 
or phrases.

If you need help beyond what is offered in this manual or in the on-line help system, 
you can turn to our technical support staff for assistance. If you are using the free, 
unlicensed  version  of  the  software  you  can  e-mail  our  technical  support  staff  at 
gradebook@surfsidesoftware.com  and  we  will  reply  on  a  time  available  basis. 
Licensed users can e-mail or call our toll free number supplied to you at the time of purchase.

Installation
We  recommend  that  you  install  the  Lighthouse  Gradebook  by  downloading  the  program  from  our  website  at 
www.surfsidesoftware.com.  This will ensure that you have the latest release with the most up-to-date features.  If you must use 
the CD to install the program be sure to check for updates when you first run the program.  You can check for updates at any 
time by clicking Help>Check for Updates within the gradebook program. 

Installing from the website
1. Download the gradebook software from our website at www.surfsidesoftware.com. Save the installation file to your 

computer.  Once it has finished downloading, double-click the file to begin the installation process.

2. At the welcome screen click the Next button to move to the next screen where you can choose the target location on 
your hard drive. This is the folder where the program files will be installed.  Unless you have a very good reason for 
doing so we recommend you keep the default location and click Next.

3. Click the Next button to begin the installation. Files will be copied onto your computer and a shortcut created on your 
desktop with which to launch the program. When the setup program has finished installing the gradebook click the 
Finish button to exit.

Installing from the CD
1. Insert the Lighthouse Gradebook CD into your CD-ROM drive. If the installation's welcome screen doesn't come right 

up then you might have auto-run turned off and will  need to begin the installation manually.  To do so, open My 
Computer, open your CD drive, and double-click the SETUP file.
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2. At the welcome screen click the Next button to move to the next screen where you can choose the target location on 
your hard drive. This is the folder where the program files will be installed. Unless you have a very good reason for 
doing so we recommend you keep the default location and click Next.

3. Click the Next button to begin the installation. Files will be copied onto your computer and a shortcut created on your 
desktop with which to launch the program. When the setup program has finished copying the file click the Finish 
button to exit.

A note about access rights
The Lighthouse Gradebook was designed to be as friendly as possible on secure computer systems such as Windows Vista. The 
initial program installation may require local administrative rights due to the fact that several system files must be installed and 
registered by Windows. Once installed, the program accesses only those areas of the computer that are typically available to a 
restricted user. This means that no areas of the registry are accessed and file-level access for important program information is 
limited to certain areas of \Documents and Settings.

Checking for product updates
You should periodically check to see if any updates to your software are available by clicking Help › Check for Updates. Such 
updates are free of charge and include additional features or fixes.

Licensing the software
The Lighthouse Gradebook can be run in either licensed or unlicensed modes. Either way offers a fully functional gradebook 
system that never expires and imposes nearly no limitations on usage. 

To license your software you will need to purchase a registration code from our sales department by calling 800-942-9008 ext 
110 or by sending an e-mail to sales@surfsidesoftware.com.

Once you have obtained your license information you can enter it into the program by selecting Help › License Your Copy.

There are three advantages to purchasing a license for your program:

● Access to  prioritized technical  support  via  e-mail.  In  the case of  a  school-wide license you'll  also gain access to 
telephone support via our toll free phone number.

● The removal of the wording "Unlicensed Copy" and “Trial Version” from all printed reports.

● The  ability  to  submit  final  averages  electronically  to  a  compatible  student  information  system,  such  as  Surfside 
Lighthouse.

Tip:  You must enter the license name and serial number exactly as they were supplied to you.  The name is 
case sensitive, while the serial number is not.  If you received the license information via e-mail it may be 
easier to copy/paste the information directly.

Removing the program
Should you wish to completely remove the Lighthouse Gradebook from your computer follow these easy steps:

1. Open the Windows Control Panel. On Windows XP you can do this by clicking Start › Settings › Control Panel.

2. Double-click the Add/Remove Program icon

3. Locate the Lighthouse Gradebook program in the list and click Remove to begin the un-install process.
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Launching the Gradebook Program
The installation of the program (described above) will create a new shortcut on your desktop, called  Lighthouse Gradebook. 
Double-click  this  icon  to  launch  the  program.   You may also  launch  the  program by  clicking  the  Start  menu,  selecting 
Programs, and locating the Lighthouse Gradebook program group.

Creating Your First Gradebook
Whether you are running the program for the first time or you just want to start a gradebook file for the next school year you 
will at some point in time need to create a new gradebook file. A gradebook file contains all of your data - everything from 
courses to assignments, students and grades.  Think of these files like a word processing or spreadsheet document – a small, 
self-contained file that can be placed anywhere on your computer or network.  

● To create a new gradebook file click File › New. 

Tip:  As with many operations in this program there are usually multiple ways to accomplish any given task. 
In the case of creating a new gradebook file you could also click the  icon in the toolbar or press Ctrl-N.

Creating your gradebook from Surfside Lighthouse
If your school uses the Surfside Lighthouse administrative software package and you have been granted access to the Teacher 
Client, your gradebook file can be created for you automatically, complete with all of your courses and students. 

● Login to the teacher client with your user name and password that were supplied to you by the main 
office.

● Click the Gradebook tab and click the Create Gradebook button.

You will be prompted for the name and location where you would like to store the file, such as in My Documents.

● Open the gradebook program and click File › Open.  Navigate to the folder where you specified the file be saved, open 
it, and verify that your courses and rosters are accurate.

Tip:  When you create a gradebook file automatically using the Teacher Client you must choose a semester 
for which rosters will be generated.  Many teachers thus prefer to start a fresh gradebook each semester. 

Gradebook wizard
The  gradebook  wizard  is  started  automatically  to  offer  its 
assistance whenever a new gradebook is created. The wizard 
will walk you through the process of creating your courses 
and entering students,  as  well  as  setting up your  term and 
category  structures,  grading  scales,  grading  symbols,  and 
assignment columns. The use of the wizard is optional since 
everything that the wizard does can also be done using the 
pull-down  menus  in  the  gradebook  itself,  but  the  wizard 
offers a lot of functionality in one easy-to-use place.

Click Next to step through the various screens of the wizard 
and answer its questions and fill in as much data as you can. 
You can always return to the wizard at a later time to pick up 
where  you  left  off.  In  order  to  begin  using  your  new 
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gradebook you should enter at least one course and a few student names. When you're satisfied with your entries click the 
Finish button to close the wizard.

➢ Launch the Gradebook Wizard at any time by clicking Help › Gradebook Wizard

Saving your gradebook file
Once the gradebook has been created you'll want to save it. Just as with a word processor, changes that you make to your 
gradebook must be saved to a file in order to make them permanent. Click File › Save to begin the process. 

You will be prompted to select the folder location where you'll store the file, which might be in your "My Documents" folder or 
someplace on your file server that your network administrator has recommended you place files so that they are backed up 
automatically. 

Once you select the folder, enter a file name and click the Save button. The file name can be any valid Windows file name, such 
as "My Gradebook" or "My 6th Grade Classes".

If you try to either exit the program or open another gradebook file without saving the current one you will be asked if you want 
to save the changes. It is very important that you answer Yes unless you have a very good reason for discarding the changes 
you've made during that session.

Tip:  You should make regular backups of your gradebook file to a flash drive, CD/DVD-ROM, or by e-
mailing the file to yourself so that a copy is retained in your e-mail history.

Copying your gradebook to another computer
Your gradebook file is a small document file, similar to a word processing document.  Because of this, it is very easy to take 
your gradebook home or put it on your laptop so that you can work on it while away from school.  

If you know where you saved your gradebook data file (and you should!) you can open that folder in Windows and copy it to a 
flash drive, burn it to a CD, or e-mail it to yourself.

To easily e-mail the file, you can click  File › Email Gradebook.  This will launch your computer's default e-mail client and 
attach your gradebook data file to the e-mail.  If for any reason this function does not work with the way your computer is 
configured, you can e-mail the file manually as described above.

Getting to Know the Gradebook Screen
The gradebook editor is similar in design to a spreadsheet program in that you enter grades into cells that are the intersection of 
a student name row and assignment column. Final student averages are calculated automatically whenever a grade changes.

Navigating around the editor
You can move the cursor around the gradebook by pressing the Up, Down, Left and Right arrow keys or by left-clicking the 
mouse in a cell. Almost all data that you see - such as grades, student names or column information - can be changed by moving 
the cursor to the cell and typing a new value. Press the Enter key to accept the new value and move the cursor down to the next 
row, or press TAB to accept the new value and move the cursor across to the next column. If you make a mistake while typing 
you can press the Escape key before leaving the cell to restore its previous value. 

If you type a value that is not appropriate for the cell you're in - 
such as a grade that is not a number and is not in your symbols list - 
the  original  value  will  be  restored  and  you'll  be  notified  of  the 
problem with a note in the status bar at the bottom of the screen.
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Getting help
There are two primary help resource screens available in the Lighthouse Gradebook.  The one you are shown will depend on 
what you activity you are performing in the program at the time of your help request.

➢ To access help, press the F1 key on your keyboard

If you are working on the main gradebook screen you will be brought to the online help system for the program.  The help 
system is organized with a list of topics on the left hand side of the screen and the contents of the topic on the right.  Click on a  
topic name to read about that topic.  An example would be a topic titled Understanding the Weighting System, which describes 
in detail how average grades are computed.

If you are on an activity window, such as adding a student or course, pressing F1 will show you a specialized help topic screen 
that explains that particular window.  The overall purpose of the window is described and each field is explained in detail. 

Toolbar and menu bar
The menu and toolbar contain all of the commands that you are able to utilize within the gradebook. The menu bar (file, edit, 
insert, etc) is a drop-down system where you click the word and a menu is displayed beneath it showing all the commands 
within that category. The toolbar beneath the menu bar contains some of the more common commands that are found within the 
menus, such as Save, Add a Student, Add an Assignment, etc.

Some commands have shortcut keys that let you press a key combination, 
such as Ctrl-S for Save. This means you hold down the Control key and 
press the letter S. If a command has a keyboard shortcut associated with it, 

the shortcut will be listed to the right of the command in the drop-down menu bar.

The toolbar can be customized to include other commands, and you can even create new toolbars in order to organize your 
frequently used commands into groups. To begin the customization process click View › Toolbars › Customize. Keyboard 
shortcuts can also be customized in a similar fashion. Customizations are saved on your computer so that they are loaded the 
next time you open the Lighthouse Gradebook program.

Keyboard Shortcuts
The following is a list of keystrokes that you can use to navigate our the program and to perform certain functions.  In many 
cases these functions can be made using the drop-down menus at the top of the screen instead of using the keyboard, and you 
can feel free to use whichever method you feel appropriate for the situation.

Keyboard Description
Arrow keys (up, down, left, right) Navigates around the gradebook screen, from assignment 

to assignment or student to student
Home Moves to the first student in the current assignment
End Moves to the last student if the current assignment
PgUp Moves up one page
PgDn Moves down one page
Escape When editing the contents of a cell, pressing Escape 

cancel that action and restores the original value.
Tab Moves to the next column to the right
Shift-Tab Moves to the previous column to the left
Enter Accepts the current value and moves down one row
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Keyboard Description
CTRL-Z Undo the last edit (same as clicking Edit › Undo)
CTRL-S Saves your gradebook
CTRL-N Adds a new assignment
CTRL-C Insert a “check mark” as a grade
CTRL-X Insert an “x-mark” as a grade
CTRL-0 Insert an “NC” grade – No Credit – averages as a zero 

but is counted as a missing assignment

Course bar
The course bar lists each course you have added to your gradebook. Click a 
course name to select it, or right-click the course name to bring up a list of 
commands applicable to that course. 

The currently selected course is displayed in red while the others are in gray. There are several different ways in which the 
course name can be displayed, such as with the period, room, or teacher names. The course bar can also be displayed along the 
top, left, right, or bottom of the screen. These settings and more can be adjusted by clicking Edit › Preferences.

Assignments area
The  assignments  area  lists  each  of  your  assignments  along  with 
several  pieces  of  standard  information  such  as  the  name,  date, 
description, term, etc.  New assignments will appear here as you add 
them to your gradebook. Only a limited number of assignments can 
fit on a single screen so it may be necessary to scroll to the left or right using the scrollbar at the bottom of the screen or the 
arrow keys. 

You can edit any piece of data for an assignment by clicking in a cell and either typing a new value or - in the case of the term 
and category - selecting from the drop down list. 

In addition to the standard information rows (name, description, term, category, date, weight, and possible) you can also display 
statistics about each column. Statistics include such computed values as the mean (average), minimum grade, maximum grade, 
range,  variance,  and standard deviation,  among others.  You can select  which statistic  rows to  display by clicking  View ›  
Statistics.  The statistic rows that you select will be display beneath the other column information rows.

Students and grades
Student names are listed down the left hand side of the gradebook. Each line can be numbered and every two rows can be 
displayed in a different color to help identify a student's grades and average. The numbering and coloring of the names is 
optional and can be changed in the preferences screen.

Grades are listed to the right of each student under the appropriate column heading. If no grade has yet been entered for an 
assignment you'll see ** (two asterisks) indicating the missing grade.

8



You can enter a new grade by clicking the cell and typing a new value.  Valid grades are all numerical grades (0-1000), NC, a 
predefined symbol, or **.  NC stands for “No Credit” and will average a zero for that assignment while still counting as a 
missing grade.  Predefined symbols can be grades such as P, F (for pass and fail) or letter grades such as A, B, C, etc.  You can  
define your list of allowed symbols by clicking View > Symbols.

Averages
To the far right of the gradebook are two columns: the student's numerical average and letter grade. These columns display the 
average for the currently selected term, semester or year, which can be changed using the tabs on the left-hand side of the 
gradebook screen.  (or by clicking View › Show Grades For). 

The average grade is calculated automatically based upon the settings you have defined.  The numerical average is a weighted 
computation of scores arrived at by examining each assignment's possible points, then taking into account any category or term 
weighting.  The resulting numerical average is then compared against the student's grading scale and a letter grade is assigned. 
This entire process is discussed in detail in the section Understanding the Weighting System.

Tip:  There is a vast number of different ways in which teachers calculate averages. It is important that you 
read and understand the section Understanding the Weighting System to configure the program to meet your 
specific needs.  

Undo
The gradebook keeps track of every change you make.  This means you can step backwards through your most recent activities 
in order to undo a mistake. Click Edit › Undo (or press CTRL-Z) to undo the most recent change. Press it again to undo the 
change before that, and so on.

Right-click context menus
You can right-click anywhere on the gradebook screen and you'll be presented with a list of options suitable for whatever it is 
you clicked. For example, if you right-click a course tab you can perform such course-related task as editing the course, deleting 
it, adjusting its grades, or moving it to another gradebook file. 

Right-clicking on a student's name lets you perform operations suitable to that student.  Right-clicking a selection of multiple 
grades lets you fill or adjust those grades, and so on. Making use of right-click context menus is not mandatory, as all of the 
functions contained in these menus are duplicated in the drop-down menus at the top of the screen. However, the context menus 
make using the program easier and more logical.

Multiple selections
If you click a cell while holding down the left mouse button and drag the mouse either left, right, up or down you'll create a 
selection area that encompasses one or more assignments, students, or grades. Many operations will then affect that entire area, 
such as filling an entire assignment with a particular grade, deleting several assignments, or changing the grading scale for 
multiple students.  After you select an area you can right-click inside the selection and you'll see a list of commands that can be 
performed on that selection.

Configuring your Gradebook
Each gradebook file contains one or more courses, and each course contains one or more students and assignments. Grades are 
entered into assignments in a very similar fashion to a spreadsheet program. The gradebook automatically computes term, 
semester and/or yearly averages as you enter the grades.
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You must configure your gradebook correctly in order to have it compute averages the way you want them computed.  Every 
teacher runs their grading system in a unique way so the exact gradebook configuration will vary from teacher to teacher and 
school to school.  

The basic premise of a gradebook program is very simple:  Enter assignment grades for students in order to print reports and 
calculate averages.  However, the reality is that - in order to work with the dozens of different grading methods that teachers 
employ - you must understand assignment points, categories, grading methods, grading scales and a handful of other concepts in 
order to ensure student averages are calculated the way that you want them to be calculated.

Tip:  Please make sure you read and understand this section of the manual, and also read Understanding the 
Weighting System, before you publish reports or submit average grades.  Do not distribute student averages 
until you are certain your calculations are working the way you want them to work.

Terms and semesters
“Terms” are analogous to marking periods and provide a way to group your assignments into logical 
units. When a new gradebook is created a default set of terms is established automatically, or if you've 
created your gradebook from Surfside Lighthouse the term structure will match that of your central 
office's system.  You can make changes to this structure as necessary.

Each assignment that you add to the gradebook will be assigned to a term, with the end result being 
that the gradebook will then be able to compute separate term and semester averages even though your 
gradebook file may contain assignments spread over the entire school year. Usually you will define 
your term structure to be the same as the grading system adopted by your school. 

You can use the gradebook wizard to manage your terms or you can click View › Terms from the pull-
down menu. You can click the Help link above the term list to view detailed information about each 
item.

➢ To view and manage your term definitions click View › Terms 

The gradebook can display your assignments contained in a single term, one semester, or all terms by clicking 
tabs on the left-hand side of the screen or by clicking the View › Show Grades For menu item.  The average 

columns on the right hand side of the gradebook update to reflect whichever term is currently selected.  

Terms can be assigned a weight.  This weight can play a large part in how the student averages are calculated. You might want 
to read over Understanding the Weighting System for a thorough, yet easy-to-understand explanation of how average grades are 
computed.

Tip:  You should NOT create a term entry for your semester averages.  Instead you should specify the 
semester number in the semester column so that the program can automatically compute semester averages 
based on term grades.  Do not create “Sem 1” or “Sem 2” entries in the term list.

Categories
Categories can be assigned to columns to specify the type of grades stored in that column. The use of 
categories allows you to see exactly how a student performed in each of your grading areas, such as 
homework,  quizzes,  and  exams.  Many reports  will  subtotal  this  category  information  and  present 
category averages for your review. 

➢ To view and manage your category definitions click View › Categories 
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Name Semester

Q1 1

Q2 1

Exam 1 1

Q3 2

Q4 2

Exam 2 2

Default Categories

Quiz

Homework

Exam



Tip:  By default the use of columns does not have an affect on the final grade calculation.  If you want to 
weight categories and have their use affect the average you can use Edit > Grading System to change your 
category averaging method.

Grading symbols
Grading symbols are letter grades or words that can be recorded as scores for an assignment column. 
Most of the time you'll enter a numerical grade for a student's assignment.  For example, a student 
might receive a 15 out of 20 possible points for a quiz.  

There are situations where it might be advantageous or necessary to record a letter grade instead of a 
numerical grade for an assignment.  Grading symbols allow you to define a letter or word that can be 
input directly as a score for an assignment.

You can manage your grading symbols by clicking View › Symbols. You can click the Help link above the symbols list to view 
detailed information about each item.

➢ To view and manage your grading symbols click View › Grading Symbols

Symbols can be notations such as Pass, Fail, Inc, or letter grades such as A, B, C. In order to compute the average grades, the 
program must be know how to turn each grading symbol into a numerical grade.  This is accomplished by entering the Value % 
for  each  grading  symbol,  which  is  the  percentage  of  the  assignment's  possible  points  to  award.   The  program uses  that 
percentage to figure a numerical grade for the assignment.  That numerical grade is then used in the average grade calculation.

Tip:  You can record a symbol as a grade for an assignment in the same way you would a number:  by typing 
the symbol's letter or name and pressing the Enter key.

Predefined grading symbols
There are 5 predefined symbols that can always be assigned as a grade, even without entering them in your Grading Symbols 
list.  This list shows each predefined symbol, its primary use, and how it will affect the student's average.

Symbol Primary Use Keyboard Average and other affects

 Positive score. Ctrl-Alt-H Affects the average if the symbol has a value defined in Preferences.  The 
assignment will not show up on a missing assignment list.

 Negative score. Ctrl-Alt-S Affects the average if the symbol has a value defined in Preferences.  The 
assignment will not show up on a missing assignment list.

 Assignment  was  turned 
in. Ctrl-C Affects the average if the symbol has a value defined in Preferences.  The 

assignment will not show up on a missing assignment list.

 Assignment  was  not 
turned in Ctrl-X Affects the average if the symbol has a value defined in Preferences.  The 

assignment will not show up on a missing assignment list.

NC No  Credit  -  Assignment 
not turned in Ctrl-Alt-N The grade is considered equal to 0 points earned, and will be averaged as 

such.  The assignment will show up on a missing assignment list. 

Aside from NC (which is always a 0), each of the other symbols can be configured to be included in or omitted from the 
student's average.  To set how each symbol is defined, click Edit › Preferences, click the Calculations tab, and set the symbols' 
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Symbol Value %

Pass 50%

Fail 90%



“value %” number.  If you leave the value blank, the symbol will not be included in the average grade calculation.    Values 
should be entered as a percentage of the total possible points for an assignment (i.e. 70=70%).

Tip:  With the exception of NC, entering a grading symbol as a score (either a predefined symbol or one you 
create) will  prevent that assignment from showing up on the student's Missing Assignment report.

Grading scales
Grading scales convert a numerical average into a letter grade.  Term, semester and final 
averages are first calculated in numerical form, and those averages are then compared to 
the each student's grading scale to derive a letter grade.  A grading scale is simply a set of 
cutoff values where each letter grade starts.   Any numerical average grade equal to or 
above that cutoff and below the next highest cutoff will be assigned that letter grade.

➢ To view and manage your grading scales click  View › Grading Scales

You can define up to 10 grading scales, and each student can be assigned a different scale. 
It is possible, for example, to specify some students in a class as belonging to an “A-F” 
scale, while other belong to an "OSNU" (outstanding, satisfactory, not-satisfactory,  and 
unsatisfactory) scale.

➢ The default grading scale for each student in a course is Scale 1.  To change a 
student's  grading  scale,  right-click  the  student's  name  and  select  Set  Grading 
Scale. 

Tip:   You can  also  create  or  modify your  grading  scales  using  the  Gradebook Wizard.   Click  Help  ›  
Gradebook Wizard to  launch the wizard,  then click the  Scales & Symbols tab.   The wizard may make 
creating your grading scales easier as it has buttons you can click to create standard grading scales such as 
A-F, A-F with +/-, and OSNU.

Changing grading scales for multiple students
Each student in a course can have their own grading scale, which defaults to “Scale 1”.  If you need to change the scale for 
every student (or just many students) you can hold down the left mouse button on the first student and drag the mouse down to 
the last student to create a multiple selection.  Then right-click on one of the selected students and choose “Set Grading Scale” 
from the menu.

Grading system setup
There are several very important options in the program that control how your average grades are calculated.  It is critical that 
you understand how these options are used and make sure you set them correctly.  Because of their importance all of these 
options are grouped together on a single screen.

To view or modify your grading system settings:

● Click Edit › Grading System 

The grading system screen contains several tabs which let you set your grading method, assignment weighting, category usage 
and more.  Click each tabs to review the settings on that page to ensure they are set to your preference.

See the section titled Understanding the Weighting System for specific examples of all of the settings on this screen.
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Calculation Method
This is perhaps the most important setting and broadly determines how your average grades are ultimately calculated.  Your 
choices are “Percentage Based” or “Points Based”.  Percentage based averaging computes a percentage for each assignment and 
then averages all of the percentages together to determine the final average.  Point based averaging adds up the total number of 
points received across all assignments and divides by the total number of possible points to arrive at an average.

Assignment Weights 
Only applicable when using a percentage based grading system, this option adds a line to each assignment called “weight” 
which lets you specify that one assignment is worth more than another within the same category or term.  If you choose to not 
allow assignment weighting the weight line will not be visible and all assignments will be treated equally within it category or 
term.

Category Usage 
Each assignment that you create can be assigned to a category so that you, the parent, and the child can track performance in 
each grading area.  However, the use of categories can have a dramatic effect on the average grade calculation.  You can either 
have the use of categories affect averages, or not.  

If you configure the program so that categories affect the average then grades are first subtotaled within each category, and the 
final grade is then an average of each category's subtotal.  You can additionally (and optionally) weight each category so that its 
grades affect the overall average more or less than another category.
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If you configure the program so that categories do not affect the average, then the use of categories is for reporting purposes 
only and their use will not affect how the final averages are calculated.  Each assignment's category will be printed on certain 
reports and many reports will show each category's subtotal for information purposes, but the final average calculation will not 
take into consideration category subtotals or category weighting.

Grading Symbols
In  addition to  numerical  grades which are  always  available,  there  are  several  predefined symbols  that  you  can use when 
recording grades for an assignment.  These are the Check, X, Happy Face and Sad Face.  In order for one of these symbols to 
have an affect on the student's average you must set a value to that symbol, which is the percentage of the possible points for the 
assignment that the symbol is worth.  If you leave a symbol's value blank it will not be included in the final grade.

Extra Credit
Each assignment is worth a certain number of points, or “possible points”.  If you record a grade for a student that exceeds that 
value the extra points can be counted and included in the average or they can be ignored.

Preferences
There are many settings in your gradebook program that affect how the program behaves.  These settings range from what you 
see on the screen such as fonts and colors, to password protecting your gradebook or changing terminology.  

➢ To modify your program settings, click Edit › Preferences

The preferences screen is organized in a tab format, with tabs for General, User Interface, Protection and Terminology.  This 
section of the manual will discuss the more important of these settings.  For a complete description of every preference setting, 
click the Help link on the preferences screen.

General School name
This is the name of your school as it will appear at the top of all reports.

Number of undo levels
This option represents the maximum number of times you can choose the Undo option (Edit ›  
Undo) to back out of a mistake you have made. For most users 20 is a sufficient escape 
margin but you are free to increase or decrease this number as you see fit.

Automatically open last active database 
This option automatically retrieves the last gradebook file that was open when you last exited 
your software.

User Interface This tab contains settings that affect how your gradebook looks.  While many of the options are 
important, none of them affect the outcome of student averages or grades and as such will not be 
discussed here.  Refer to the online help system by clicking the Help link on the preferences 
screen.

Protection Using the Protection tab you can put a password on your gradebook file so that your data cannot 
be viewed with a standard text editor.  When you attempt to open a password protected gradebook 
file, you will be prompted for a password each time.

Terminology The Terminology tab lets you change the words used to describe several key program items.  For 
example, we refer to “assignments”, “courses” and “categories”.  You may prefer “subject” or 
“bin”, etc.
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Courses and Students

Adding courses
Each course tab contains a roster of students in your class, as well as its own set of assignment columns for which grades can be 
entered.   You should add one course tab for each section of a course you teach.  You can use the gradebook wizard (Help ›  
Gradebook Wizard) to add your courses or you can click Insert › Course from the pull-down menu.

➢ To add a new course click Insert › Course 

When adding a new course, the course name is the only mandatory piece of information but the other fields have the following 
uses:

● Course Name – The name of the course as it will appear on reports.  If you will be sending your grades back to a 
compatible Student Information System such as Lighthouse the name should be spelled exactly as it is in the other 
software.

● Section – The course section.  Be sure it is the same as listed in your Student Information System.

● Teacher Name – The name of the teacher as it will appear on reports.  The teacher name is also very important if you 
will be uploading your grades to our MyStudentData.com on-line website.

● Teacher ID – The ID number for the teacher as it is listed in your Student Information System.  It is very important 
this number matches your other software in order to facilitate the transfer of grades back and forth.  The teacher ID is 
also used when uploading grades to our MyStudentData.com on-line website to associate a teacher account with a PIN 
number.

● Period and Room – These pieces of information are shown on several screens and printed on certain reports.  They are 
optional but should be entered when possible.

● Grading System – Each course can have its own grading system (Percentage-based or Total Points).  By default all 
courses use the grading system that was defined when you created the gradebook or by clicking Edit > Grading System.

Tip:  If your gradebook was created for you automatically by the  Surfside Lighthouse Teacher Client you 
will likely not have to add any new course tabs manually, nor should you change the Teacher Name or 
Teacher ID without good reason.

Adding students
Within each course tab is maintained a roster of students enrolled in 
the class. Each course has its own separate roster, so adding, editing 
or  removing  students  from one  course  does  not  affect  any  other 
course. 

A student must be added to the course roster before you may enter 
grades for that student. As with your course definitions, you can use 
the gradebook wizard to add your students or you can click Insert ›  
Student from the pull-down menu. To edit a student, right-click the 
student's name and click Edit Student.

➢ To add a new student click  Insert › Student

Even if you are using a student information system such as Surfside 
Lighthouse that has prepared your gradebook for you, student adds 
and drops throughout the year  must be edited manually into your 
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gradebook.  There is not a direct link between your gradebook and the main office, so changes the office makes to student 
schedules do not show up in your gradebook, and vice versa.  

The Student ID # and Birthdate are particularly important fields.  These two fields are the primary determining factor 
used to match students between your gradebook and the office's database, so make sure to enter them accurately.

Several student fields are very important and care should be taken when changing the data.  

● Student Name – Usually entered as Last Name, First Name, the student's name will show up on just about every 
report.  When sending average grades back to a student information system, the student's name will be used in the 
absence of a Student ID # when matching students to the main school database.  If your gradebook file was created for 
you automatically, do not change the student's name unless you have a good reason.

● Student ID # - This number is used to match your students to those in the school's main database when automatically 
submitting average grades.  You should not change this number for existing students without a very good reason.  For 
new students joining your class after the gradebook is initially created, enter the student ID# exactly as it was supplied 
to you.  Failure to enter a correct ID# may affect the accuracy of the term averages you submit back to the school 
system.

● Birthdate – The date of birth may be used to match your students to those in the school's main database.  Specifically, 
if your student has a birth date that is different from the one stored in the main database, the matching system may not 
think it's the correct student.  Do not change this date for existing students, and for new students ensure that the birth 
date is entered correctly.  

● Nickname – This is the name the student may prefer to be called and may optionally be displayed on your main 
gradebook screen.  Nicknames will never appear on reports.

● Gender – Male or female.  This is for your reference only.  When using the Grouping tool you can choose to group 
students evenly by gender.

● Address – This is for your reference only and is not used by the gradebook program in any way.

● Parent's name and phone numbers – For your reference only and does not appear on any reports.

● Counselor – For your reference only and does not appear on any reports.

● Grading  Scale –  The  student's  grading  scale  determines  what  final  letter  grade  will  be  received  for  any  given 
numerical average.  You can define more than one grading scale and each student can be set to any scale.

Tip: For sorting purposes we recommend that you enter student names in a Last Name, First Name format. 

Changing student records
If  your  gradebook was  created  for  you  automatically  by the  Surfside  Lighthouse  Teacher  Client,  much of  each student's 
information may already be filled in for you.  You may change any piece of information, and that change will affect your 
gradebook only.  None of your changes will be sent back to the main school database.

You should take special care to ensure that the student ID # and Birthdate are kept up-to-date with your school's Student 
Information System to facilitate the transfer of grades between programs.

● You can edit a student's record by right-clicking a student name and selecting Edit Student

Dropping students
If a student drops from your course, you have the option of deleting the student or dropping the student.  Deleting the student 
will  erase the student and all  grades associated with that student completely from your gradebook.  Dropping the student 
preserves the existing grades for the student but prevents that student from receiving a final average and from showing up on 
reports.
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➢ To drop a student, right click the student's name and click Drop Student

➢ To delete a student, right click the student's name and click Delete Student

Tip:  If a student attended your class and received any grades, we recommended that you drop the student 
rather than delete her.  This will preserve her grades for future reference.

Changing a student's record
A student's record contains some basic demographic information, such as birth date, gender, address, and phone numbers.  Most 
of the field are for your reference purposes only and needn't be used unless you require them.

➢ To edit a student's record, right click the student's name and click Edit Student. 

Sorting students
Students can be displayed in your gradebook sorted in a particular order.  By default the students are arranged alphabetically 
from A to Z, but you can change this order.  In addition to sorting by student name, you can also sort students based on their 
score for any assignment.

➢ To sort students alphabetically right-click the student name column and choose one of the Sort Students selections to 
sort either in ascending or descending order.

➢ To sort students based on the grades received for a particular assignment, right-click anywhere in the column and 
choose one of the Sort Scores selections to sort either in ascending or descending order.

Displaying student nicknames
Normally the gradebook screen displays the student's full name as you entered it into your course roster (typically in Last, First  
format).  You can show the student nicknames by clicking View > Show Student Nicknames.  Students that do not have a 
nickname entered on their student record will continue to show the full name.

Entering Grades

Adding assignments 
Assignments can be quizzes, tests, exam, homework or any other grade that you want to track as part of a student's progress in 
your course.  Columns are specific to each course, meaning that each of your courses has its own set of assignments for which 
to enter grades and those assignments are not shared amongst any of your other courses. To add a new assignments click Insert  
› Assignment or press CTRL-N. You can click the Help link above the scales list to view detailed information about each item.

➢ To  add  a  new  assignment  to  your  gradebook  click   Insert  ›  
Assignment

Each assignment has several fields which together control how it behaves 
in your gradebook.  For each assignment it is important that you correctly 
specify each field's value, as several of them can drastically affect the 
grading calculations.

Name -  The assignment name is  displayed at  the head of  the 
column when you're working in the gradebook and is printed on 
most reports.  The column name can be any number of characters 
but many report will be presented better if you keep this name as short as possible. 
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Description - The description is a longer explanation of the assignment's meaning and also appears on many reports. 
While the name should be kept short the description can be any length.  However, because the description also appears 
on some reports, verbosity can cause some reports to look cluttered.

Date - The date refers to the date that the grades in the column were due or assigned. Printed reports usually list the 
most recent assignments first, and the gradebook screen itself can also be sorted by date. There are no restrictions on 
the format of the date you use, so it's acceptable to enter dates in "8-15-06", "8/15/2006", or any other format you 
choose. It's best to be consistent in the format you use so that reports look better. It is not absolutely necessary to enter a 
date for a column, but you'll lose the ability to sort your gradebook on the date of the assignment and on printed reports 
you'll not see the date of missing work.

Possible Points - The possible points is the total number of points that a student can receive for that assignment. For 
example, a quiz may have 10 and a standard test might have 100.  

Weight – If you are using a Percentage Based grading method (as opposed to a Total Points method) you can set  each 
assignment  to  be  weighted  against  one  another,  relative  to  other  assignments  within  the  same  category,  term or 
semester.  For example, if you have a particular homework that is worth more than most other homework assignments 
you could give that assignment twice the weight as the others.  Note that if you assign a weight to even one assignment 
then you should be consistent and assign a weight  to them all  so that it  is clear exactly how the final average is 
computed.  When using a  Total Points method of grade calculations (as discussed in  Understanding the Weighting 
System) assignment weighting is disabled and not available for use.

Term – The term (marking period) to  which the assignment belongs.   You must  specify a term in order  for  the 
assignment to be placed into your gradebook properly. 

Category –  The use of categories allows you to see exactly how a student performed in each of your grading areas, 
such as homework, quizzes, and exams.  Because the use of categories can drastically affect your averages, you should 
read Understanding the Weighting System before using categories. 

Extra credit assignment – If this box is checked then the assignment is considered to be worth extra credit and may 
help but will not hurt the student's average.  In the case of a  Total Points  grading system the number of points the 
student received will be added to his or her total, without adding to the total number of possible points, thus increasing 
the average.  For  Percentage Based  grading the non-extra credit average is first calculated and then the extra credit 
assignments are included only if they do not bring down the average.

Entering grades
Grades are entered at the intersection of a student row and assignment. Select the desired cell by left-clicking the mouse or 
using the arrow keys, and then type a numerical value or the name of a pre-defined symbol into that cell. Press the Enter key to 
accept the grade and move to the next student or press the Tab key to accept the grade and move to the next column. If you want 
to edit an existing value instead of typing a new one then double-click the cell to go into edit mode.

To delete a grade, select the cell and either press the  Del key or type an asterisk (*). An asterisk is considered a no-grade 
symbol and indicates that the student is missing a grade for that assignment column. Missing grades do not count for or against 
the student are a completely omitted from the average grade calculation.

Tip:  As you add, change, or delete grades the students' averages will be updated automatically to reflect the 
new grades.  

Extra credit assignments
When you add a new assignment to your gradebook it  does not affect a student's average until you enter a grade for that 
assignment.  That is because each cell in a new column has a default grade of **, which does not factor into the average.  What 
this means is that any assignment can be treated like an extra credit assignment simply by leaving the grade blank for those 
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students who do not turn in the assignment.  If a grade is entered it will be factored into the average, and if a grade not entered it 
will not affect the average.

When you add a new assignment you can place a check mark in the “extra credit assignment” box which takes extra credit a 
step further.  For any student who receives a grade for the assignment it will help but never hurt that student's average.

Tip:  Lighthouse Gradebook now supports a “help but not hurt” extra credit system.  When you add a new 
assignment place a check mark in “extra credit assignment” and the grade they receive may help but will 
never hurt that student's average.

Sorting columns
As you add new columns to your gradebook they are added as the rightmost column in your gradebook.  That is unless you have 
specified a column sorting setting, in which case the column will be positioned according to your sort settings.  You can sort 
your columns by name, date, category, weight, and possible points.  

➢ To sort your gradebook columns click View › Sort Columns and select one of the sorting methods.

For the most part, sorting the columns only affects the screen display and not printed reports.  Most reports list assignments in 
date order.

Tip:  You can remove column sorting from your gradebook and return the columns to their originally entered 
order by selecting Unsorted from the column sorting options.

Filling an entire assignment with a default grade
Usually you will enter grades for an assignment one student at a time.  However there are times when it is faster or easier to fill 
an entire assignment with a single grade, and then go back and make changes to those students who have a different grade.

➢ To fill grades for an assignment, right click anywhere in the column and click Fill Column.  Type a numerical grade or 
symbol to fill and click the Ok button.

When filling a column you can choose whether to fill a grade for every student or for only those students who are missing a  
grade.  If it's a new assignment that you are filling the choice will not matter, but if it's one that already has grades you must  
make sure to not accidentally erase your grades.  If you do make a mistake, click Edit › Undo and try again.

Tip:  You can also fill a student, a selection, or even an entire course with a grade.  Clicking the right mouse 
button on a student's name, a course tab, or a selection of grades will allow you to select that object's  Fill 
function.

Adjusting student grades for an entire assignment 
You can adjust grades for an entire assignment, such as to add a certain number of points to a test or adding a percentage to 
each student's grade.  Adjusting grades can be useful when you need to rescale a test or quiz.

➢ To adjust grades for an assignment, right click anywhere in the column and click Adjust Column.  Type an adjustment 
amount, specify how the amount will affect the existing grades (add or subtract a value or percentage), and click the Ok 
button.
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Override a student's average grade
Student averages are calculated automatically whenever you add, change or delete grades.  Your gradebook can calculate term, 
semester and yearly averages and you control the way that average is determined as described in Understanding the Weighting 
System.  

You will usually want to let the program calculate your averages automatically, but there are times when you might want to 
override this calculation in order to consider factors such as class participation, improvement, or other subjective concerns.  To 
do so, click to select the average grade you wish to override in the far-right grade column and then type the new letter grade.  
The newly entered grade will be underlined to indicate that it is an override.

When you have created an override for a student, changes you make to that student's grades will not affect his average.  In order 
to remove the override and revert that student to using the automatic calculation, select the overridden grade and press the 
Delete button. 

If when you enter or change grades for a student it is not updating the final average look to see if the average grade is  
underlined.  If it is, then it means that the grade has an override that you must delete before the program will continue 
to calculate the average automatically.

Tip:  If you find that you are entering manual overrides for a large majority of your students you may want 
to  look  at  how you  have  configured  the  program to  calculate  your  averages  and  make  adjustments  as 
necessary.

Copying students to another course
If you have a student that moves to another section of a course you can copy that student to the new course complete with all of 
the grades that have already been entered.  

To copy a student:

● Select the student that you wish to copy to another course section

● Click Edit > Copy to Another Course

If the student already exists in the new course, or if any of the assignment names do not exist in the new course then you'll be 
prompted to confirm the process.

Moving or copying a course to another gradebook
There are times when you might want to copy an entire course - complete with student records, assignments and grades – to 
another course.

To move or copy a course to a new gradebook:

● Right-click the course tab and select Move or Copy Course

You will have the option of copying the course, which will leave all of grades alone in the current gradebook, or moving the 
course, which will delete the entire course record from your current gradebook.

Copying a course within the same gradebook
You can create a copy of any course in the gradebook, which will copy all student records, assignments and grades to a new 
course tab.

To copy a course within the same gradebook:

● Right-click the course tab and select Duplicate 
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Understanding the Weighting System
At the simplest level the student's average is be the sum of all the grades in your gradebook, divided by the total number of 
grades. However, that wouldn't allow you to produce separate term and semester averages or to specify that exams count more 
toward the average than homework assignments. For these and other such tasks you need to turn to the weighting and grouping 
systems provided in Lighthouse Gradebook.

Attention:  It is very important that you read and understand the weighting and grouping system before you 
publish any grades or submit any averages.  There are many ways that teachers calculate averages.  You 
must configure the program properly in order to produce the results that you need.  Lighthouse Gradebook 
computes averages exactly as you have instructed it.  If your instructions are incorrect, the averages will be 
incorrect.

Grouping
There are two primary levels of grouping that occur when grades are calculated: term grouping and semester grouping. A third 
grouping of  categories can be enabled in the Grading System setup screen, but it is disabled by default.  Before going on to 
discuss the weighting system it is important to understand how these groupings can affect the students' final averages.

Term and semester grouping involve the program taking all of the grades within a particular term and averaging them together 
to produce a term subtotal.  All of the term subtotals are then averaged together to produce the semester average.  In the same 
way, each semester's subtotal is calculated and then averaged together to produce the yearly average.  So in essence all term 
grades are “grouped” together, and all semester grades are grouped together.  

((Term 1 subtotal) + (Term 2 subtotal)) / 2 = Semester Average

((Semester 1 subtotal) + (Semester 2 subtotal)) / 2 = Yearly Average

Weighting
The weighting system allows you to count more heavily one assignment,  category subtotal or term subtotal  over another. 
Through the use of weighting you can tell the program that you want  Exams to count more towards the term average than 
Homework, or that you want Term 1 and Term 2 to count twice as much as the Mid-Term Exam grade.

There are 3 types of weighting that you can employ:  category, and term and assignment.

Category weighting 
By default category weighting is disabled and the use of categories is for reporting purposes only and does not affect the 
average grade calculation.  If you want to enable the use of categories for grouping and weighting purposes you can use 
Edit › Grading System and turn on category averaging.

Each category that  you create can be assigned a weight.   When calculating averages each category is first  subtotaled and 
averaged together with all the other category subtotals.  By using weights you can specify exactly how much each category is 
figured into the term average.   

➢ To weight your categories, click View › Categories.

There are two important points to remember when using category weighting:

1. If you assign a weight greater than zero to any category, then you should assign a weight to all categories so that it is 
clear exactly how each category subtotal affects the average grade.

2. A categories weight is proportional to those from other categories.  For example, if you want Tests to be counted twice 
as much as Quizzes, enter a value for Tests that is twice as much as the value for Quizzes.  You could use 2 and 1, 4 and 
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2, or 100 and 50.  So long as you are consistent in your use of weights the actual numbers used don't matter, only their 
relation to the other categories.  It may be convenient to have all of your category weights add up to 100.

Note:  If you are have not enabled category averaging as defined in Edit › Grading System, then categories 
are effectively ignored in the average grade calculation and any weights you enter will be discarded. 

Term weighting
Each of your terms (also called marking periods) can be weighted in order to compute a semester average.  Without weighting, 
the semester average is each term's subtotal divided by the number of terms.  With weighting you can, for example, indicate that 
Term 1 and Term 2 should have equal weight and count for 80% of the semester, while the Mid-Term Exam counts for 20%. 

➢ To weight your terms, click View › Terms and Semesters.

 There are two important points to remember when using term weighting:

1. If you assign a weight greater than zero to  any term, then you should assign a weight to  all terms so that it is clear 
exactly how each terms subtotal affects the semester average.

2. A terms weight is proportion to those from other terms.  For example, if you want Term 1 and Term 2 to be counted 
twice as much as the Mid-Term Exam, enter a value for Term 1 and Term 2 that is twice as much as the value for Mid-
Term Exam.  You could use 2/2/1, 4/4/2, or 40/40/20.  So long as you are consistent in your use of weights the actual  
numbers used don't matter, only their relation to the other terms.  It may be convenient to have all of your term weights 
add up to 100.

Tip:  You can have the program tell you exactly how it is calculating a student's average by printing the 
Explain  Student's  Average report.   This  report  is  invaluable  in  diagnosing  discrepancies  between  your 
personal calculation method and the one you told the program to use.

Assignment weighting
Each assignment can be weighted so that it counts more towards the average than other assignments within the same 
category or term.  Note that assignment weighting is disabled by default, and is not applicable when using a Total Points 
grading method.  If you want to use enable assignment weighting you must 
turn it on using Edit › Grading System.

When enabled, each assignment has a “weight” line, which is where you can 
specify how that assignment's grades relate to the other assignments within the 
same category or term.  If you leave the weight line at 0 (the default) then all 
assignments  within  that  category  will  be  treated  equally.   If  you  want  one 
assignment  to  count  more  than  another,  you  can  enter  a  weight  for  the 
assignment  that  is  proportionally  more  than  the  other  assignments.   Each 
assignment will then be weighted based on how the assignment's weight relates 
to the other columns.    

➢ To weight an assignment, enter a number into the column's “weight” line

There are three important points to remember when using assignment weighting:

1. Assignment weighting applies only to assignments within the same category.   This means that weights within the 
“homework” category will not be factored against weights in the “tests” category.

2. If you assign a weight greater than zero to any assignment, then you must assign a weight to all assignments within the 
same category.  Failure to do so will cause all assignments with a weight of 0 to be excluded from the average.
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3. An assignment's weight value is proportion to those in the other assignments.  For example, if you want Quiz1 to be 
counted twice as much as Quiz2, enter a value for Quiz1 that is twice as much as the value for Quiz2.  You could use 2 
and 1, 4 and 2, or 100 and 50.  So long as you are consistent in your use of weights the actual numbers used don't  
matter, only their relation to the other assignment weights.

Tip:  If you find that you are assigning the same weight to all assignments within a given category, such as 
all Tests with a weight of 2, then you might be better served using category weighting instead of assignment 
weighting.

Averaging methods
There are many ways in which teachers compute their averages - so many that it's not possible just to choose your averaging 
method from a list and have the program adjust itself accordingly.  Instead, you will tell the program how you want the averages 
calculated through the use of a calculation method, assignment weighting, category usage, and extra credit – in essence all of 
the settings available in Edit › Grading System.

If you have not yet read through the rest of this Understanding the Weighting System section of the manual we suggest you do 
so.  It contains very import information that you need to know in order to have the program calculate accurate averages the way 
that you want them calculated.  

Following are several of the more popular types of averaging systems, with an explanation on how to configure your gradebook 
to use that system.  These should be used as a guide in setting up your own gradebook.

Method name Percentage-based with categories

Description The  percentage-based with  categories method  uses  categories  to  subtotal  all  assignments 
within each category, and then each category's subtotals are averaged together to produce a 
term average.   Each assignment  is  treated  equally  within  its  respective category,  with the 
student's grade being calculated as a percentage of 100%

Steps 1. Click Edit ›  Grading System and on that screen set the following:

● On the Calculation Method tab set Percentage based.
● On the Assignment Weights tab set whichever preference you desire, with 

the default being Do Not Allow Assignment Weighting.
● On the Category Usage tab set Categories Affect Averages

Create your category names and weights using  View ›  Categories.  The use of weights is 
optional, but if you assign weights then the term average will be a weighted average of all the 
category subtotals.

● For each assignment you create:
1. Be sure to assign a category to every assignment.
2. Student grades for the assignment will be factored as a percentage of the 
Possible Points.  For example, an 8 out of 10 possible equals 80%.  This 
80% will be averaged with the other assignments within the category.
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Method name Percentage-based  without categories

Description The percentage-based without categories method uses categories for reporting purposes only 
and their use does not affect the average grade calculation.  Each assignment is treated equally 
within its  respective category,  with the student's grade being calculated as a percentage of 
100%

Steps 2. Click Edit › Grading System and on that screen set the following:

● On the Calculation Method tab set Percentage based.

● On the Assignment Weights tab set whichever preference you desire, with the default 
being Do Not Allow Assignment Weighting.

● On the Category Usage tab set Categories Do Not Affect Averages

You may create categories using View ›  Categories and each assignment can still be given an 
category, but their use will not affect the average grade calculation.  If you assign a weight to a 
category it will be ignored.

● For each assignment you create:

1. Assign a category to each assignment if you wish.

2. Student grades for the assignment will  be factored as a percentage of the Possible 
Points.  For example, an 8 out of 10 possible equals 80%.  This 80% will be averaged 
with the other grades across the entire term.

Method name Total points method with categories

Description The  total points  with categories method has each assignment valued at a certain number of 
points.  Each grade a student receives for an assignment is added to his total, and the final 
average is the total received divided by the total possible.  This method uses categories, so all 
assignments within each category are added up and subtotaled, and then divided by the total 
number of categories to produce the term average.

Steps Click Edit › Grading System and on that screen set the following:

● On the Calculation Method tab set Points based.

● On the Assignment Weights tab set whichever preference you desire, with the default 
being Do Not Allow Assignment Weighting.

● On the Category Usage tab set Categories Affect Averages

Create your category names and weights using  View ›  Categories.  The use of weights is 
optional, but if you assign weights then the term average will be a weighted average of all the 
category subtotals.

● For each assignment you create:

1. Be sure to assign a category to every assignment.

2. Enter the possible points for the assignment.  Student grades for the assignment will 
be added to all other assignments within the same category.  The category subtotal 
will then be the total points received divided by the total number possible.  Example: 
8 of 10 and 7 of 10 equals 15 of 20, or 75% for the homework category.
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Method name Total points method without categories

Description The  total  points  without categories method has each assignment being valued at  a certain 
number of points.  Each grade a student receives for an assignment is added to his total, and 
the  final  average  is  the  total  received  divided  by  the  total  possible.    This  method  uses 
categories only to designate the type of each assignment, but does not use category subtotals to 
affect the term averages

Steps Click Edit › Grading System and on that screen set the following:

● On the Calculation Method tab set Points based.

● On the Assignment Weights tab set whichever preference you desire, with the default 
being Do Not Allow Assignment Weighting.

● On the Category Usage tab set Categories Do Not Affect Averages

You may create categories using View ›  Categories and each assignment can still be given an 
category, but their use will not affect the average grade calculation.  If you assign a weight to a 
category it will be ignored.

For each assignment you create:

1. Assign a category to an assignment if desired.  Since the use of categories do not 
affect the average grade it does not hurt to use categories for some assignments but 
not others.

2. Enter the possible points for the assignment.  Student grades for the assignment will 
be added to all other assignments across the entire term.  The term average will be the 
total points received divided by the total points possible.  Example:  8 of 10 and 7 of 
10 equals 15 of 20, or 75%.

Explain student's average report
The  Explain Student's Average report is designed to assist you in understanding exactly how the program has computed a 
student's term or semester average.  If you find that the program's average does not agree with your calculations, this can be an 
invaluable tool in diagnosing the problem.

➢ To run the average explanation report, click Reports › Explain Student's Average

The average grade explanation shown in Figure 1 is for a very simple average grade calculation in which a student received 
grades in two columns within the Quiz category for Term Q1.  The grades are 90 and 100.

As you follow from the top to bottom, notice the indenting of each section of the report.  The indenting shows that a new 
subtotal section has been started - such as a semester, term or category grouping.  In this example, the two grades are shown at 
the bottom under the  Quiz category.  The  Quiz line prints the total points for all grades in that category and divides by the 
number of grades to produce a Quiz category subtotal of 95.00.  This being a very simple example there are no grades in any 
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other category or term, so the 95.00 average is raised upwards through each subsequent level of grouping – term, semester and 
finally year.

In Figure 2, we've added a grade of 85 to the Homework category.  In this example, the Quiz category is weighted at 40% and 
the Homework category at 20% (an unused Exam category is weighted at 40% for a total of 100% across all categories).  In the 
Grading System screen we've set categories so that they affect the average grade calculation.

Once  again  looking  at  the  indentation  shows the  various  levels  of  grouping.   The  furthest  indented  lines  are  the  grades 
themselves.  Each category subtotals its own grades to derive a category average.  In this case, the Quiz category subtotals to 95 
and the Homework category subtotals to 85.

Since in this example the categories are weighted as 40% and 20%, the term average is not a simple average of the two category 
subtotals.  That would not take the weighting into account.  Instead what happens is that each category subtotal is multiplied by 
its weight to produce a weighted subtotal.   The weighted subtotals are then divided by the total weight to produce a term 
average.  If you look at the “Term Q1” line you'll notice a value of 5500 / 60.

In this example, the Quiz category is weighted at 40% so we multiply 95 * 40 = 3800.  The Homework category is weighted at 
20% so we multiply 85 * 20 = 1700.  The total of the weighted category subtotals is 3800 + 1700 = 5500.  This number is 
divided by the total of all category weights, in this case 40 + 20 = 60.  5500 / 60 = 91.68, which is our final average.

Both of these examples are fairly simple in that there are not many grades and all of the grades are assigned to the same term.  
However, even when printing an explanation for a student with a complete set of yearly grades all of the same principles apply, 
and if you step through each level of subtotals you can figure out exactly how you've instructed the program to calculate your 
averages.

Reports
Lighthouse Gradebook offers many reports that contain different views of your data. All reports share a common interface that 
lets you zoom in and out, scroll, change the report settings and layout, print or e-mail the report, and other tasks.

To produce a report click the Reports menu and select the desired report from the drop-down menu.
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Navigating the preview screen

The navigation bar across the top shows you the current page and total number of pages in a Current/Total Pages format. You 
can click the left and right arrows to move forward and backwards through the pages in your document, or directly to the 
beginning and end. If there is only one page in the document these buttons will be dimmed and not available (as shown above).

The magnifying glass controls the zoom, which lets you move in to see a bigger view of the document or zoom out to see more 
of the page. Clicking the magnifying glass once will zoom to 100% scale, which is actual size. Clicking it again will zoom to 
"whole page" which lets you see the layout of the entire page, usually at the expense of not being able to read the text. You can 
click the down arrow button next to the magnifying glass to select from a few preset zoom levels. You can also double-left click 
anywhere in the document to zoom in, or double-right click to zoom out.

If the entire page does not fit within the current window then scroll bars will appear on the right hand side of the page and/or at  
the bottom. Use these scroll bars to uncover areas of the document that you can't see. You can also click and hold the mouse 
button anywhere in the document and drag the mouse to scroll.

Common report tasks
Every report screen has the same set of common tasks that let you interact with the report in various ways:

Print this report - Sends the report to the printer. After clicking this link a standard Windows Print dialog will be shown that 
lets you select the destination printer as well as adjust certain printer settings. The exact settings that you can change - and even 
the look of the print dialog screen - will depend on your version of Windows and the type of printer you're using. But in most 
cases you can at least select the pages to print, the number of copies, and the page orientation (portrait or landscape).

Save to PDF file - Saves the entire document to an Adobe Acrobat (PDF) file. PDF files are industry standard files that can be 
shared with other users. All that is required in order to view a PDF file is a free piece of software called Acrobat Reader which 
is available on Adobe's website.
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Email report - The option first automatically saves the report to a PDF file, then launches your e-mail client (such as Outlook) 
and attaches the report file. If for any reason the program is not able to locate your e-mail client software to automate this 
process you can still save the file to a PDF and e-mail the file yourself. 

Change report settings - Each report can be customized in various 
ways, from wording to colors, fonts, and content. The options are 
grouped together with each other so that it's easy to locate those in 
which  you  are  interested.  The  groupings  are  Captions,  Colors, 
Content (not shown), Font (not shown) and General (not  shown). 
Clicking  any item displays  at  the  bottom of  the  window a  short 
explanation of what it does.

As  you  make  change  to  the  various  settings  the  report  will  be 
automatically updated to reflect the new values. Usually the update 
takes place immediately letting you get instant feedback about how 
the report will look, but if the report takes a long time to generate it 
will  not  be redrawn with your  changes until  you click the Close 
button.

When making changes to colors, fonts and yes/no values you can 
double-click the item to change its value.

Reset report defaults - Any changes that you make to the report 
settings will be saved along with the gradebook file and applied the 
next time you produce the report. This is usually a good thing and 
allows you to  customize your reports  to your liking and use that 
format throughout the year. However, if for any reason you want to 
revert back to the default layout then click this link.

Page  setup -  This  launches  the  printer's  page  setup  dialog  that 
typically lets you adjust the paper size and source, page orientation 
(portrait or landscape) and margins. The exact settings that you can 
change will  depend on your version of Windows and the type of 
printer you're using. Any changes that you make in the page setup 
dialog will be saved along with the gradebook and reapplied the next time you produce the report.

Close report - Closes the report preview and brings you back to your gradebook screen.

Student selection
When you select a student-based report, only the currently selected student in your gradebook will be processed. If you want to 
include all  students or select certain students then you can click the  All Students and  Choose Students links, respectively. 
Clicking the One Student link will always revert back to the student that is currently selected in the gradebook.

Term selection
Certain reports gather their data from one or more terms (marking periods) or semesters. This data might be column scores, 
missing assignments, or averages. The currently selected term or semester being viewed in your gradebook will be used when 
producing a new report, but you can select a different one if desired. The report itself will always in some way indicate from 
where it is gathering its data with wording such as "Final Average" or "Q1 Grade". 

Progress report
The progress report is designed to show an individual student's performance in your class.  Printed is the term or semester 
average, any missing work, that student's rank in the class, and information about the most recent assignments.  Each category is 
subtotaled at the bottom of the report, and your grading scale is printed in order to explain the number to letter conversion.
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This report only prints on a single page.  If you need to print more assignments than will fit on a single page, use the Scores 
report.

Scores
The scores report is designed to show all of an individual student's assignment grades in your course.  Printed is the term or 
semester average, any missing work, that student's rank in the class, and all assignments.  

Missing assignments
The missing assignments report is designed to show a list of any missing assignments for an individual student.  Printed is the 
term or semester average, a list of the most recent completed assignments, that student's rank in the class, and a list of all the 
missing assignments.

Assignment report
The assignment report is designed to show the details of an individual assignment.  Printed is the basic assignment information 
(name, category,  term, date, and possible points), statistics (average, min, max, etc), students who have not completed the 
assignment, a breakdown of grades, and the scores for each student.

Class summary
The class summary report is designed to show each students' current progress in your course.  Printed is some basic course 
statistics, a break of grades, and the term average for each student.

Spreadsheet of columns
The spreadsheet report is designed to print your gradebook in a manner similar to what you see on your screen.  Printed is a 
column for each assignment, and each student shows all assignment grades plus the term, semester, or final average.

Explain student's average
The explain averages report is designed to assist you in understanding exactly how the program has computed a student's term 
or semester average.  There are many ways in which averages can be calculated, and for a complete explanation of all those 
options you should read Understanding the Weighting System.  If you find that the gradebook program's average does not agree 
with yours, this can be an invaluable tool in diagnosing the problem.

Sending averages to Surfside Lighthouse
If you have licensed your copy of Lighthouse Gradebook then you can submit your term or semester averages back to the 
Surfside Lighthouse Teacher Client in order to help speed entry of grades to the office.

Your gradebook program may be located on your school computer, your laptop, or maybe on your home computer. Because of 
this flexibility it is not possible for the Lighthouse Teacher Client to directly read your gradebook file and extract the student 
averages.

Instead, you will create an “averages file” that contains student averages in a standard format that the Lighthouse Teacher Client 
can understand. Once the file has been created, you can then bring that file to your computer at school and use the gradebook 
tab of the Teacher Client to import the averages file.

If Gradebook is installed on the same computer as your Lighthouse Teacher Client
• Click File=>Send Averages to Lighthouse
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• A file containing your student averages will be saved automatically to your computer in a location your Teacher Client 
knows about. The next step is to open your Teacher Client, click the Grades or Mid-Term tab, then click the "Import 
Grades" button to begin the process or reading your averages into Lighthouse.

If Gradebook is not installed on the same computer as your Lighthouse Teacher Client
• To create your averages file that will be sent to Lighthouse on a different computer, click File › Save Averages for 

Student System

• You must specify which term or semester averages you want to submit to Surfside Lighthouse by placing a check mark 
next to each item.

• Click the Select button to specify where the “averages file” will be placed. A good place to save this file is on your 
Desktop with a name of “Averages”.

• Click the OK button to save the averages to the file.

• Open your Teacher Client, click the Gradebook tab, then click the Import Gradebook button to begin the process of 
reading your averages into Lighthouse.

Uploading grades to MyStudentData.com
If your school subscribes to Surfside's MyStudentData.com Internet student data 
access service you may be able to upload your grades to the website so that 
parents  and  students  can  view  the  grades  securely  from  from  their  home 
computer.  

➢ To  upload  grades  to  MyStudentData.com,  click  File  ›  Upload  to 
MyStudentData.com

Logging in
You will be required to enter a username and password, which will be supplied 
to you by your school's administration.  This username and password is shared 
by every teacher in your school.  

The first time you login you will be required to create a PIN number.  This PIN 
number can be any number 3 or more characters in length.  This PIN number 
belongs to you alone and it will be required each time you upload.  The PIN will 
ensure that no other teacher can affect the grades you have uploaded.  

Once you enter your username, password and PIN, click the Login button to attempt to login to the website.  Any login errors 
will be reported at the bottom of the screen.

The PIN number is associated with the Teacher ID that is entered into the first course in your gradebook.  In 
other words, since all teachers share a username and password the way that each individual teacher account 
is distinguished from each other is by each having a unique Teacher ID and PIN number.  It is important that 
you ensure that you fill in the Teacher ID field with the number supplied to you by the main office.

Preparing your gradebook for uploading
When you upload your gradebook to MyStudentData.com you are sending individual student assignment grades to the website 
so they can be viewed by parents and students.  Each course that you select will be uploaded and the grades for all assignments 
within the term you chose will be uploaded, along with each student's current term average grade.
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But there's more to the puzzle than just uploading your gradebook and having parents be able to view the grades. Your data by 
itself is not sufficient for a parent to be able to retrieve the student record, because your gradebook does not contain all of the 
important data associated with each student; most of that information resides in your school's main Student Information System 
software, such as Surfside Lighthouse.  

To provide the extra information not contained in your gradebook, the office uploads the student records from their software 
and you upload the grades from your software, and the two together combine to provide all of the information necessary to 
retrieve a student and view the grades.

Importance of Student ID numbers
In order for your student records to match the student records uploaded by the office there has to be some way to link a student 
record contained in one system to the same student record from a different system.  Matching students by their name is not a 
very good idea because not only do some students have the same name, more commonly there are differences in the way that 
one person might enter and spell a name versus another person.  To a computer, “Joe Smith” does not equal “Joey Smith”.

To combat this problem of matching students we use unique student ID numbers.  The main office records an ID number for 
each student, and you record that same ID numbers for each student in your gradebook.  Then when you upload your gradebook 
the program will be able to match your students with those uploaded by the office and ensure that the grades are placed into the 
correct student records.

It is extremely important that you ensure that each student has a valid, up-to-date ID number in your gradebook before 
uploading.  At any time you can view your student ID's by clicking Help › Gradebook Wizard and clicking the Students tab.  If 
you  initially  created your  gradebook using the automatic  function in  the Lighthouse Teacher Client  then your student  ID 
numbers will likely be filled in and correct since that data is coming directly from the main office.  However, it is ultimately 
your responsibility to ensure that your data is accurate.  Anytime you add a new student you must get that student's ID from the 
office and enter it as part of the student's record otherwise his grades will not be uploaded.

Course name, teacher name and teacher ID
When you upload your grades you are sending more than just the student records – you are also sending some basic course 
information as well as your name, which will all be displayed to the parent or student.  You should ensure that each course is 
spelled correctly, and that each course has your name listed in the Teacher field.  You can click  Help › Gradebook Wizard and 
click the Courses tab to view and edit this information.

In order to match you with your PIN number you must enter a valid Teacher ID for each course.  This ID is usually supplied to 
you by the main office, and if you have used the Lighthouse Teacher Client to create your gradebook then it will already be 
filled in.  This ID is used, along with your PIN number, to ensure your authenticity.  The ID number should be unique across all 
teachers in your school.  In you do not enter a Teacher ID for a course you will not be able to upload its grades. 

Uploading grades
Once you enter your username, password and PIN and click the Login button you will be able to choose the term and select 
which courses to upload.  Place a check mark next to each course and click the Begin Upload button to start the upload process.

Depending on the speed of your Internet connection and how much data you are uploading it can take anywhere from a few 
seconds to a few minutes to complete the process.  Make sure you do not interrupt the upload process, even if it looks like the 
program has stopped responding. 

If you do not see one of your courses listed, be sure the course has been assigned a Teacher Name and 
Teacher ID.  Without these pieces of information the course cannot be uploaded and will not be visible on 
the list.  You can view your course settings by clicking  Help › Gradebook Wizard and then clicking the 
Courses tab.
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Errors
Once it has finished uploading the program will notify you of any errors that might have been encountered.  The most common 
error is that a student will have been uploaded that does not have a matching record as uploaded by the main office.  This is 
usually caused by a having an incorrect student ID number listed in your gradebook.  Correct the mistake and re-upload, or 
contact the office to help resolve the situation.
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